Reinstall metamask wallet but can't find my coins?

I had to reinstall my metamask wallet and did it whit 12 seed words.
That worked fine.
Imported a new BSC chain and have eth in main account and bnb in BSc chain account.
I tried to added and find my safe moon and blink coins.
Added the contract adres etc… All good but no coins?
My old wallet had a imported account also so I also imported that account with private key did al the things above but also no coins?

My main question… Is the main metamask wallet key words also the recovery for all the coins on that wallet… Includes the the imported wallets on BSc chain.
Iam afraid I lost them…
Thanks in advance for any help on this.

All the imported accounts have a different address.
I can see my coins on the wallet address. I Gould find it back from a transfer from a friend to my wallet.
I thought one recovery key is for all the coins on metamask and BSc chain coins.

Im having a similar issue so, please keep me informed on your progress

I will… I hope I find them back some howe​:+1::blush:

I looks like every imported account I did before don’t have them also.
The main account imported with recovery words don’t have them also after installing BSc chain.
The adres where they on now I can’t find back any more.
Same issue you have.

sorry to hear that i am also having the same problem tokens gone and money gone in bscscan you will see all transactions and contract # i have been tryin with no luck and support does not seem to be helping much. if you get help please post.