Unable to import JSON vault data into Metamask iOS wallet

Hi there,

Following the instructions for importing vault data (as described at https://metamask.zendesk.com/hc/en-us/articles/360018766351-How-to-use-the-Vault-Decryptor-with-the-MetaMask-Vault-Data), I find I’m unable to import the following into the Secret Recovery Phrase area, instead I get this: “Error Secret Recovery Phrases contain 12, 15, 18, 21, or 24 words”

Here’s the text I’m trying to import, note I’ve replaced some data with the string ‘private’ as I’m posting this on a public forum.

Can anyone assist please?

{“cipher”:“YRpASQmET7WnNLpR5/7HI0Yd7TFuiAKPsreJSWpgt8DW1lXMWl/5fqe7ri5tnfdn6GIvlprivateprivateHzPoeCfi2Cx2MBayQRfMYh4ry+SLI7C1Ki+h9q+t4QdFb8fa6PXY/5djFmuHyGXgCJK9WMchfV9jjQj3ujQRhs8i4fpBV42RTs7udQbkkDB7cV84ZlprivateprivateHj6NbG55fjB6fiMHlIjlAUK4=”,“iv”:“7d00e1cb49ba12e5bade84691e34b6b3”,“salt”:“UXcUV0p1BiXGmPZIaL6mog==”,“lib”:“original”}

Any pointers much appreciated !

Thanks, Chris

Hey @ChrisDC, welcome to the MetaMask community! :fox_face:

You actually don’t paste that part directly into the Secret Recovery Phrase area, you paste it into the Vault Decryptor which will reveal your 12-word Secret Recovery Phrase, which is what you type in to recover your account.

As mentioned in the Knowledge Base article you linked:

  • Modify the object to reflect the example below (manually remove all \\ and ensure there are no white spaces):
  • {"cipher":"JaX8Z80QMzzqA4XMgPsUuleNLIuxvchXZ5q1SO9GO1kuNUmokUke06op9EF0ZU4WssILfUZ0yKI5kjzYY9H12t5aGb43BOAWJwlKuC8neXWeL5enoD/L05eDC9tzZEBupLwF7cGG6JdPHHQKdRDWWbQM+TUo6EvZv7LClPZQVJ17uowGvPMPB0UwXPea7DP/dE5DYleHmX1rhxAJr1YN4HUPAYpCCReU4W4/2QsaM+E=","iv":"dcabe6ed590ae3ee8e056c7844c583d7","salt":"h6IkHlWjloBgc9+KiGTYvQ==","lib":"original"}
  • This should get you to a point were you can copy the vault into the the mobile application!
2 Likes

Thank you Winnie,

I had tried this as well but without success either unfortunately.

However I will double check the password! Maybe it is wrong

Thank you for replying :+1:

Best, Chris

Hi, @ChrisDC, did you use Word editor to delete the \ symbols ? It seems that Word modified the quotes symbols, it should not be curve as on your example. That is probably the reason why the cipher is not recognised. Try « Notes » instead, there’s also a function find and replace, and it will not modify the style.

1 Like

@ChrisDC it should looks like this:

But if that is for professional propose, I deserve a tip :rofl:

Hi MomOfTwins,

I don’t believe it’s an encoding problem - here’s the txt as it appears in Vault Decryptor - it all looks right…

This data is not for vault decryptor, but for Mobil app. But the second screenshot looks good :+1:

1 Like

Here’s what I get - notice the error at the bottom

Are you using the same mobile device? With the passwords you used with the vault?

This is a customer’s iPhone. We extracted the necessary data (above), and they have literally supplied almost 300 possible passwords…

Rather than try them all on an iPhone, I’m using the Metamask extension on Brave.

Is there by any chance an API where I can feed all the passwords in instead of manually going through them??

But if I try on an iPhone, I get the same error about 12,15,18,24 seed words…

It’s likely that the password is incorrect, which is decrypting the wrong phrase from the vault causing the error to show up.

Not sure of any API where you can feed the passwords in :slightly_frowning_face:

1 Like

Yes that’s a good point about the password being incorrect, but I get the error even before I enter a password…

@ChrisDC it’s normal that chomium extension UI doesn’t accept cipher and doesn’t allow you to enter the password :wink: It doesn’t supposed to do that!

1 Like

Yes so I guess the only course of action is to manually enter these 300 passwords one by one on the iphone. Great…

Sorted it and wrote a post about it too on the web site:

@MomOfTwins and @nakedwinnie thanks very much for your time and input.

Glad to hear that! :slight_smile:

1 Like

:+1:

Happy for your client!

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.