Can´t fedge Chain ID on BSC

Hi MM Support and Community,

first: i know there are a lot of topics regarding this but im unable to fix my problem.

Im using BSC and MM for a while already and suddenly this problem appeared.
At first it began only at night times like past 11pm for a few days, but it got worse until now having the problem all day long.
when i deleted and tried to readd the bsc network as my first try to fix it, i realized its this error causing my problems.
what happens when i use bsc:
sometimes i can use bsc normally for a minute and suddenly nothing loads anymore, pending transactions might fail aswell. it takes a lot more time for it to start working again as its actually working. (like 80% downtime)
i literally tried every solution i found here and using google.
for example:
all other RPCs
resetting my router
clearing cache and everything
completely reinstalling google chrome and metamask
using VPN
switching between MM accounts and networks
…i might even forgot something

to be clear: everything works totally fine except the BSC network and whenever the problem appears and i switch to another chain, then back to bsc it just loads forever.
when i then try to add or delete a “/” in the BSC network options it gives me the error “cant fedge chain id…” (tried this multiple times to see if that is what causes the problem for sure)

after struggling for a week i found a little but really annoying workaround:
i turn on or off VPN and switch to a different BSC RPC → works for a minute → repeat

i really dont want to keep going like this :frowning: as it still causes transactions to fail and a lot of extra time to do anything

same problem on my phone what made me think its my connection but how am i only having trouble with bsc?
and suddenly after months without problems?
why VPN isnt helping?

would really appreciate any additional suggestion how to fix this or what might cause this problem.


I’m not the administrator or mod here.
I am people of the community.

Have you tried reset your account yet?

1 Like

yes tried already numerous times

Hey @Raiserist, sorry to hear this is happening.

If you would like, you can submit a ticket to our support team here with the issue: and click Start a Conversation

This topic was automatically closed after 30 days. New replies are no longer allowed.