Cannot connect to Sepeolia Test Network

I cannot connect to the Sepolia Test network. Using the RPC mainnet.infura io v3 and chain 1 - Tried to reboot etc without any luck. Please advise.

hey, I can use Sepolia normally.
Have you tried adding Sepolia’s rpc using chainlist?

1 Like

I have a current lock on the Sepolia Test network so I am not sure how I can modify it. Also any details on how to add the chainlist would be appreciated…

search Sepolia on, then add rpc as this.


Hi @ericjfromm , welcome to MetaMask community!

You can enable testnets directly from within your MetaMask wallet. Check this article on how to do it:


All test networks are enabled… I still cannot connect to Sepolia Test network. Is there a way that I can remove the lock along side the existing network? I would like to delete it and try to re-add it

If testnet is enabled, can I try to re-add and view the RPC issue?


Please see my first message regarding the RPC network. This is the network I am try to connect to


Attached are the details for the Sepolia network

This is the erro message

Sepolia test network works fine for me, I personally think it’s your network, I’ve had similar problems with other networks!
Try adding what tuya said


How can I change it - It shows a lock along side of the network and will not allow me to edit the network - See image above.

Also the network above is not the Sophia Test network - That is the product network.

Check “Include Testnet” , you will see the Sepolia network below. Select an RPC to add.


This topic was automatically closed after 30 days. New replies are no longer allowed.