Can't withdraw USDT on Waves network

Hello. I deposited USDT on the waves MetaMask network, now I’m trying to withdraw it from MetaMask, but I can’t do it. I do not even open the form for entering the wallet. Waiting all the time

1 Like

Hello @Immix, welcome to MetaMask community!

Try switching multiple times between the networks you have added in your MetaMask wallet and try again. If that doesn’t work, try removing USDT and re-add it as a token and if that doesn’t work then remove Waves network and re-add it, making sure you have the correct information of the network from official sources.

1 Like

I tried all this, the representatives of the Waves network said that the problem is on the MetaMask side, but could not offer a way for me to withdraw my USDT through another network. For example trc-20 or bep-20.

I tried through the browser and through the Google Chrome extension

1 Like

Can you try reinstalling the extension, fresh, and try again, and only add Waves network besides the ETH network, adding USDT for Waves network again and give it a shot? Also try another browser, like Firefox.

1 Like

It doesn’t help, I tried. Using MetaMask, it is not possible to programmatically send tokens on the Waves network. Maybe you can pull up the wallet through another service using a crochet phrase and try it? But I don’t know which one

1 Like

It would be best if you contact Support team at https://metamask.zendesk.com/hc/en-us and click Start a conversation

support

Once you click Start a conversation a live chat bot will appear on your screen. It will give you an automated response at first, but afterwards you should be able to contact the support team directly.

2 Likes