How do I remove $Rune from Metamask? I tried to swap some $RUNE into $ETH and it disappeared

How do I remove $Rune from MetaMask? I tried to swap some $RUNE into $ETH and it disappeared from my MetaMask wallet, when I look at the swap details on ethscan, it shows 0. I originally swapped from $ETH into $RUNE months ago and just left it in my MetaMask wallet, now I am not sure what to do, and I’ve lost 50 x $Rune tokens, and still have more in my MetaMask wallet.

Hi friend. Please feel free to share your address and I’ll take a look into it.

2 Likes

OK thanks:
0x1F593136e3ebd70d5dAD8bFF94bA80523BeCd112

May I ask if you are referring to this transaction as shown in the screenshot swaping 50 Rune with Ethereum


In such case you have swapped rune with eth on eth mainnet

4 Likes

As @Mandip mentioned, you have swapped your Rune for ETH and the ETH are available on your wallet.

You can see the ETH been credited to your address under “internal txs”.

3 Likes

Yes, that’s the transaction

OK so it looks like I’m only getting 10% of the value of the RUNE in ETH?
Can anyone suggest any swap to get any better value out of the RUNE?

Many thanks for any help anyone can provide.