More than 5 hours But Funds not showing in my wallet

A friend of mine sent some USDC to me almost 5 hours ago. The transaction was successful I checked through the hash. But I can’t see the tokens in my meta wallet. Searching for a solution since morning, watched videos read posts. But so far no success.

Here is the hash 0x40f00e4680620dcb881d4d69cb8f8cf38a322cd115a6f26542c92cd1ddf962ce
If someone could help. It would be great.

Let me know if need more info

Hello Muhammad :point_down: this is your Metamask ETH address ?

Try open this page :point_down: and click on fox :fox_face:

OR click Add token - Custom Token and add contract address:

Thank Lugi for the reply. I add through custom token as you said above. But still the same. Not showing, 0 USDC.
Any idea how to solve it?

You use ethereum mainnet? :slightly_smiling_face: next idea :grinning_face_with_smiling_eyes: open this page :point_down:

and click Add Token to MetaMask

yes eth mainnet was used. But still the same :frowning:
No success.

OK I’ll send you a private message :upside_down_face: it will be safer