Withdrawal from AAVE fails due to error with eth_estimateGas call


for several days now I cannot withdraw stETH from AAVE v2 because of this error. AAVE v3 does not have that issue! Reinstalling MetaMask on a different browser won’t help. Below the error message when entering some number in the Withdrawal prompt of AAVE v2 interface:

There was some error. Please try changing the parameters or copy the error:

RotationProvider exceeded max number of retries. Last error: processing response error (body=“{"jsonrpc":"2.0","id":80,"error":{"code":-32000,"message":"could not find latest block in cache or db"}}”, error={“code”:-32000}, requestBody=“{"method":"eth_estimateGas","params":[{"value":"0x0","from":"[REMOVED]","to":"0x7d2768de32b0b80b7a3454c06bdac94a69ddc7a9","data":"0x69328dec000000000000000000000000ae7ab96520de3a18e5e111b5eaab095312d7fe84000000000000000000000000000000000000000000000000000000003b9aca000000000000000000000000003c9ea5c4fec2a77e23dd82539f4414266fe8f757"}],"id":80,"jsonrpc":"2.0"}”, requestMethod=“POST”, url=“cloudflare-eth COM v1/mainnet”, code=SERVER_ERROR, version=web/5.5.1)

Thanks for your help!


I had to change the cloudflare-eth url so it is not considered a link by the forum software. Also revmoed the address in the from field.

Hi @aiinv do you still have an issue? Have you tried checking with aave protocol team

problem is still there. The problem seems to be with the gas estimate API. Shall I turn to them?

And it also happens on AAVE V3 by the way when repaying USDT loans. USDC however worked.

RotationProvider exceeded max number of retries. Last error: processing response error (body=“{"jsonrpc":"2.0","id":80,"error":{"code":-32000,"message":"could not find latest block in cache or db"}}”, error={“code”:-32000}, requestBody=“{"method":"eth_estimateGas","params":[{"value":"0x0","from":"[REMOVED]","to":"0x7d2768de32b0b80b7a3454c06bdac94a69ddc7a9","data":"0x69328dec000000000000000000000000ae7ab96520de3a18e5e111b5eaab095312d7fe84000000000000000000000000000[REMOVED]"}],"id":80,"jsonrpc":"2.0"}”, requestMethod=“POST”, url=“https :// cloudflare-eth .com / v1/mainnet”, code=SERVER_ERROR, version=web/5.5.1)

1 Like

Thanks for the update, where is this screenshot taken from?

Firefox browser. AAVE V2. OS: Linux . But had the same issue on a different browser, so it doesn’t seem to matter.

I contacted AAVE support as well and asked them to reply in this thread if they can.

Great thanks for sharing, let’s wait for them to reply first please

1 Like

This is from them. Hi you won’t be able to perform actions until the DAO performs an update, there was a vulnerability identified and to avoid any loss the reserves were either paused or frozen, there is a voting by the DAO in place to fix the problem, which would take 3-5 days to be implemented (the time is shorter for ETH markets but slightly longer for non ETH networks), you can find additional context at:
https x :// x governance . aave . com /t/ aave-v2-v3-security-incident-04-11-2023/15335/2
https x :// x app . aave . com / governance/proposal/ ?proposalId=358

ok, there is a warning on AAVE V2, but nothing on V3, which is also affected by the same thing. I will wait 5 days and revert back. Thanks @oxroo

1 Like

is it working fine with MetaMask extension

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.