Address has gone missing and not sure how to recover it

I was using my ledger to access the binance smart chain thru metamask. I had it all working, but when I wanted to unstake my pancake tokens, the ledger never got the chance to approve the transaction.

So I decided to clear the addresses and reinstall them. The problem came when the BSC address never reappeared. Not sure where why the address does not show up in metamask.
any ideas?

Hi @Middelman thanks for reaching out!

Do you still have an issue with it? Could you share an example of a BSC address? Let us know where you are with it.

Kind regards,

Yes I still have an issue with this.
Here is what I did: https://docs.binance.org/smart-chain/wallet/ledger.html

Here is the address: 0x0Bc0518aA9C47b39597888B0AaD56B842dAAf605

More detail if needed:

I recently transferred BNB from Binance to the Binance Chain network (using the Ledger). However I was unable to use this BNB with Dapps like PancakeSwap.

I did some research and found out that I might be able to use the Binance Smart Chain extension wallet on Chrome to transfer the funds from the Binance Chain to the Binance Smart Chain. I connected my Ledger to the extension and sure enough, I could see the BNB on the Binance Chain. The address started with bnb…

I then switched over to the Binance Smart Chain Network (at the top of the extension) and it showed me a new address starting with 0x0…with the word Ledger beside it. I assumed that this was the smart-chain equivalent of the bnb… address, generated by the Ledger.

I tried a small transfer at first and the transfer was successful. I later transferred the rest of the BNB.

I thought everything went well until I tried the new Binance Smart Chain address (starting with 0x0…) on PancakeSwap. But I was not getting the signature authorization on my ledger when I want to complete the transaction. I tried to send the funds to another Smart Chain address and I still did not receive the signature authorization. I could see the BNB in the 0x0…address (that was generated by the Ledger) but I could not do anything with it. I tried multiple browsers, reinstalled extension, tried metamask, cleared cache, no luck.

Today I logged in through the Ledger and Binance Smart extension and I don’t even see the address anymore! The address is obviously still on the Binance Smart Chain but I have no way to access it. I looked through all the addresses in the Ledger using https://mycrypto.com/ and it doesn’t find the BSC address that it generated yesterday! How is it possible that the Ledger could create an address that it no longer has!? Anyone in a similar situation?

Hi @middelman,

If you go to Connect Hardware Wallet while on Binance Smart Chain, you should be able to re-add that account.

I’ve tried that but no account shows up.

When you say “no account shows up” do you mean literally there are no accounts and you can’t connect the hardware wallet? Or you just don’t see the account that you are looking for.

I don’t see the account I am looking for.

Hmm, it sounds like you may have previously connected your ledger using a different derivation path. When you connect your hardware wallet, there is a drop down menu to switch the derivation path. You can read more about it here:

https://metamask.zendesk.com/hc/en-us/articles/360020394612-How-to-connect-a-Trezor-or-Ledger-Hardware-Wallet

Hi thanks for the suggestion. I tried it, but no luck. Are there other derivation paths I can try?

you tried each option?

Yes, live and legacy. Tried it a few times.

Maybe try installing with your seed phrase on a different browser / device and seeing if you have the same issue? What you’re describing seems impossible to me… A seed phrase can’t produce completely different account addresses unless it is following a different derivation path.