Brave and metamask dosent work

Hi, Iv encountered a problem signing in with MetaMask using the Brave brower recently. I double checked with Chrome and also using brave on Mac, which worked. however it did not on Windows. Is it a known issue, or is there annything i can do?

This is what it says in the metamask when i try using anny Dapp

“We noticed that the current website tried to use the removed window.web3 API. If the site appears to be broken, please click here for more information.”

Cant find annyyhing about it online. Would love some help!


Have encountered the same issue since Friday hopefully someone can help.


tengo el mismo p`roblema. no se me conecta con pancake ni poocoin


Same. Extension version 9.8.2

1 Like

me neither it just does nothing at all thought it may have been a windows update but have not had any since 14-07 hopefully there is a metamask update to cure this.


Yeah… ive serched all over the internet cant find annything… so weird.


I’m on macOS v11.4, using Brave and MetaMask extension. Brave
Version 1.27.108 Chromium: 92.0.4515.107 (Official Build) (x86_64)

1 Like

My friend sat on a Mac beside me with all the same uppdates and it worked… i think its something on Brave and windows.

1 Like

I’m on a Mac, I can’t connect to any Dapp sites.


oh man… thats weird… Hope we get some help with this…


alguien pudo solucionarlo???

Translate … could someone fix it ???

Yeah i hope we get a uppdate really soon…

or do like i did, i use Google Chrome or Metamask browser on your phone…
But i like Brave so hope they fix it!

The api popup suggests downloading Metamask legacy web3 extension. After downloading and a few tries, it was pointing to Crypto Wallets in Brave for some reason. I started a new Brave wallet, cleared Brave’s cache and reset my metamask account. I then disabled crypto wallets in brave. The Metamask extension in Brave is now working. I would start by downloading the legacy extension, and then disabling “load crypto wallets on startup” in Brave settings. If doesn’t work, you can then try clearing Brave’s/Chrome’s cache and resetting your metamask.

Can confirm, this appears to be an issue with brave on windows specifically.

I’m wary of trying out another legacy metamask extension, I expect stealing a seed phrase would be quite easy with something like this and it does not appear to be supported or recommended by the metamask team.

Hi managed to sort mine by going into Brave settings and turning off (Load crypto wallets on startup) then restarting browser hope this may help some of you.


This worked! Thank you!!

Yeah! Thanks it worked!! awesome man!

This works, thanks a lot

Thank you so much it worked !!

Can’t link it, as new user the link for legacy web3 was in Metamask support. The popup for it was also in metamask, so it’s not third party.