Brave browser not connecting to MetaMask

No matter which web3 page I open, when using Brave Browser the initialisation of MetaMask doesnt open. Other browsers like Chrome work flawlessly.

Are there some brave://settings I can configure or activate in the configuration so that MM cooperates? Or has brave prevented any kind of interaction with MM to use their own Brave wallet? There must be some kind of work around to enforce the web3 page to interact with the MM extension, or not ?

I am not on desktop but Surface tablet (windows). 4 months ago Zendesk provided this guide but it is completely unefficient:

1 Like

Hello @anoni1 !
Welcome to the MetaMask community !

Please ensure you are using the latest version of the Brave.


I found a post about Brave last year, someone mentioned a solution, you can try it.

I started a new Brave wallet, cleared Brave’s cache and reset my MetaMask account. I then disabled crypto wallets in brave. The MetaMask extension in Brave is now working. I would start by downloading the legacy extension, and then disabling “load crypto wallets on startup” in Brave settings. If doesn’t work, you can then try clearing Brave’s/Chrome’s cache and resetting your MetaMask.
-----------by jiteshj

You can click on the title to see the full discussion.


I have the latest Brave version (downloaded it yesterday), though I cant disable “load crypto wallets on startup” because this option doesn’t even show on the latest version! Did they remove it?

Or is this “legacy” version a specific windows version i need to download on my surface tablet?

Thanks for supporting!


I just downloaded the extension for Mac. and didn’t find this option either, it seems it has been removed.
The Mac version works fine. :smile:
hope others can help you :thinking:


Thanks Tuya… could any devs, experts or support team please reply ?


Hi @anoni1

I am not a developer, but I was thinking of this setting to also try: enabling browser permissions? It’s worth a try :slight_smile:


This topic was automatically closed after 30 days. New replies are no longer allowed.