BUSD missing after swap, please help

Hello, I made a swap from BNB to BUSD and was successful, but the token is nowhere to be found. I had sent BUSD from BSC to my Metamask but the same problem occurred, all receipts showing ‘‘successful’’ but the amount, nowhere to be found. I’ve changed the browser today to try to see if something happens, imported all tokens and reconfigured all the networks, but still nothing. I have all the transactions if necessary. Can somebody help me? Thank you! (I already send a Ticket to support but no response until now, all this happened yesterday and the problem persists)

6 Likes

same problem :confused: with the same token. Did you have a solution?

0x78e5ff87ba6b29975e6683cd5509911b0044edc077cc9548eea3ec92ae99d5f4

No, still waiting for a response from the ticket I sent… this is really annoying.

Hey @Henryk, welcome to the MetaMask community! :fox_face:

Thank you for submitting a ticket to our support team. They will be with you as soon as they can.

This is likely because of an issue with Binance Smart Chain’s RPC nodes that recently happened.

And their response:

1 Like

Thank you! My ticket was responded, waiting now to see if the problem will be resolved.

3 Likes

did you have a solution? or what did they tell you?

Henry, did they help you with the problem? I can see the same

@Sebastian90 and @RuslanRu

Please make sure your wallet is configured to the right network and that you have imported the correct contract address for the token.

If the issue still persists, try these steps in our Knowledge Base:

Just to answer here, I already did this and did not work.
I got a response for my ticket and now I’m waiting yet another response, because my problem was not resolved yet…
And yesterday, I made a swap with pancake for a test and guest what? Nothing of BUSD in my wallet. This is very disappointing and frustrating…

And now I noticed that my ticket is being categorized like ‘Solved’ , and I can’t believe that this was done if my problem is still here and I never got a solution to the problem. Unbelievable…

Hey @Henryk, sorry to hear this has happened.

What was your Ticket #? I will let the support team know to revisit the ticket you have submitted.

Hi, my Ticket was updated with ‘‘pending’’, now trying to solve the problem. Thank you very much!

1 Like

Hi Henryk,

I had the same problem and I did add the token again. Find the right token to add. It was weird that I found 3 logos of BUSD. The 1st and 2nd one were wrong so the amounts have not been shown. The amount showed immediately once I added the right token to Metamask. Try it.

2 Likes

Hello,
I tried 2 different addresses that I took from CoinMarketCap, but neither worked.