Cloning MetaMask results in "LavaPack is not defined"

I am just trying to clone the metamask using

MetaMask/metamask-extension from github

I am just following the docs, but ended up in error when access the extension via browser
Uncaught ReferenceError: LavaPack is not defined
context
background.html

I have tried to get it resolve but unable to find any clue

1 Like

yes already tried, but again it gives same errors

I guess you took it wrong. I am cloning the the metaMask by using its code from github, and during following the described process i am facing this error

Uncaught ReferenceError: LavaPack is not defined
context
background.html

Anyone up? please
for guidance

Running with this branch lavamoat-dev-optional resolves the issue.

1 Like

Hi,
How can I fix this problem? I have the same
Thank you.

It was fixed by building up the build using node 14.15.0 version

1 Like

I am using node 16.4.1, you mean I have to install node 14.15.0 version?

“engines”: {
“node”: “^14.15.1”,
“yarn”: “^1.16.0”
You mean change this node to “14.15.0”?

Yes you can try with 14.15.0 node it might help

1 Like

try again,fix your wallet with sth

1 Like

I could run “yarn dist” and “Load” to Chrome without the error “LavaPack is not defined” before.
After a lot of modification, I can not “Load” to Chrome (because of this error). I think is it the policy of Lavamoat?

Just go with this branch of metaMask repo
“lavamoat-dev-optional”

Use node 14.15.0
and follow the normal instructions as given in readme. It will not cause the lavamoat issue.

1 Like

Command failed with signal “SIGTRAP”
“LavaPack is not defined” is fixed, I run it ok. But now I have another mistake. It is “Command failed with signal “SIGTRAP” when I run " yarn dist”. This happens both my files and original Metamask files. Can you help me?