Metamask buttons not responding after cloning the repository

I have followed the instruction given in the MetaMask github to run MetaMask extension on local network
but after adding it as extension on chrome and firefox, “i agree” button is not responding.

to put in short
After cloning the MetaMask-externsion repo, and adding the build in chrome extension, I was not able to click the buttons in the cloned MetaMask.
Let me know if there is any additional information required to solve this.

1 Like

Hi thanks for opening a new post. Could you share browser logs please what happens in console when you click “Agree” what other button did you try clicking both?



Please check

1 Like

getting same error on both button

Thanks @user1142 could you please double-check your setup and the versions you are running if it continues to happen please open a github issue under this repo.

Yes i have checked that. Let me explain the steps i have done

  1. clone the MetaMask-extension with version 11.16.0
  2. Use the command corepack enable in MetaMask-extension project.
  3. put the infura api key in .metamaskrc
  4. yarn install
  5. yarn dist
  6. In load unpacked of chrome extension, added the dist>chrome folder
    Node version 20.14.0
    MetaMask version 11.16.0
1 Like

it is working with yarn start but not with yarn dist. I think the issue is with lavamoat

Thanks for extra details have you opened an issue, sharing the details above

I have solved it on my own. There is issue in the code. How can i contribute it ?

Awesome you can open PR as mentioned on discord