Error connecting to Binance Smart Chain

This is not a new issue, but I have not seen a post about it recently. Just today, after using this account for over two years, I can no longer connect to my Binance Smart Chain network. Any attempts to edit the network account RPC URL to alternates fail. When I attempt to switch to it I get the “Connecting to BNB Smart Chain” message and then “Oops! Something went wrong.” My MM extension and Chrome browser is up to date. Any ideas?


Hi @buddyia
One thing you can try is to remove the network and then add it back again.

And also make sure the browser permissions are on →


I get this warning under the Chain ID
Could not fetch chain ID. Is your RPC URL correct?

It almost looks like a network error, except nobody else is posting about it. It makes me afraid to delete it, although I guess it does not matter if I can’t connect to it anyway.

1 Like

I would try to remove it and add it back again, see if that fixes it. No harm in that.
And also clear browser cache and cookies.


I did all and nothing is changed.

hi. What Urban.Moods provides is the commonly used method.

There is some similar post here, you can try using the information provided by Luigi.


Then yes, just like @tuya advised above, this would have been my next suggestion, to re-add the network with a different rpc :slight_smile:


Ok trying all of these.

So far I get - Could not fetch chain ID. Is your RPC URL correct? after entering 56 or 0x38 in the chain ID.

Try using a different RPC Endpoint (URL) :point_down: you can find them here:

Or try to add the BNB Chain network with the help of the website:


Ahhh you guys are good. I just start using different RPC URLs off of chainlist until one didn’t reject the Chain ID and then it worked. Thanks so much!


Of course, you are welcome! Glad we were all able to help here and also thanks for taking the time to let us know it worked :slight_smile: