Eth classisc not showing up

I am new to Metamask and had transferred ETH Classic from Trust Wallet to Metamask but it is not displaying in the account.Please help me into this.

Hi rahuls.usts try :point_down:
https://metamask.zendesk.com/hc/en-us/articles/360058809292-How-to-view-ETC-Ethereum-Classic-token-
OR

Hi Lugi,

I cannot find the option of Custom RPC in the app and is there any other way of getting the coins as it already been gone from Trust wallter.I saw the transaction on Metamask but did not got the time to take a snapshot…Any other idea about this?

You are using a Metamask on your mobile?

1 Like

Thanks Mate…it worked…had a sigh of relief…looks like you have very good knowlwedge and lastly can you let me know how i can swap etherneum classic to Space Hoge as for that only i switched all the coins to Metamask…Thanks once again.

1 Like

You need ETH or WETH :slightly_smiling_face: :point_down:

Sorry, but it doesn’t help. I am told: “Could not fetch chain ID. Is your RPC URL correct?”

Hi @DanylaCrazy try the page https://chainlist.org/

doesn’t help, i am told “Request for method 'eth_chainId on ethereumclassic.network failed”

@DanylaCrazy hmm you’re right :roll_eyes: :+1: it’s not working

not working

https://www.ethercluster.com/etc
Because this address has a problem :slightly_smiling_face:

Update :grinning_face_with_smiling_eyes: now it works

Network Name: Ethereum Classic
New RPC URL: https://www.ethercluster.com/etc
Chain ID: 61
Currency Symbol (optional): ETC
Block Explorer URL (optional): https://blockscout.com/etc/mainnet/

2 Likes