I can't select another network

I’m really disappointed in you guys, why do you make such low-level mistakes, I accidentally selected the Rinkeby network, and it reminded me that the network is disabled, I can’t turn off this prompt, I can only switch networks, but choose to switch networks, The network window is one level down and I can’t select another network

Hello @user2275 !
Welcome to MetaMask community !)

This problem has already been raised in the next topic.
Check this should help you:

1 Like

I am having the same problem but on firefox setup. There is no option even to hide the popup using developer toolbar in firefox.

I cant do anything with MetaMask. I have the same error. Deleting that id element does nothing. HELP

@user2294 @user2294

Do you know and keep your seed phrase in a safe place?
If so, then probably reinstalling the wallet will solve this problem.

:exclamation::exclamation::exclamation: do not do this if you do not remember your seed phrase or it’s lost!


In case you don’t know the seed phrase :point_down: try to find vault data

Instruction for Firefox:


Helo MetaMask. So I added rinkeby testnet when performing a task then trying to switch back the wallet has refused to switch networks yet I wanna receive my funds. How do I switch the network back to eth or other networks. Been trying for weeks

Hey @kr3pt0, welcome to the MetaMask community! :fox_face:

This issue will be solved in the next version, 10.33, for a temporary workaround see here:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.