I did not get my token using the Swap button

I did the swap BNB to DVR using the Swap button. Metamask took BNB tokens but didn’t return DVR. It was 3 days ago. The technical support does not answer. I am sure that the token is a legitimate. I checked its contract adress. And I tried to swap again with Pancakeswap and it was successful. All transactions can be tracked at bscscan
I provided all the links and evidence in detail in the support letter, but no one answers. The wallet 0xc590175e458b83680867afd273527ff58f74c02b are used in all your swaps. What is this wallet?
I can’t use my tokens the third day.

1 Like

Sorry the helpdesk isn’t responding quickly. We’re working on increasing our staffing to better support our growing userbase.

Try checking your transaction hash. The most likely answer is the DVR token wasn’t added to Metamask’s display. (How to View Your Custom Tokens in MetaMask)

The 0xc59 address is listed a a contract address on several different blockchain explorers. Though none of them give more specific detail.

It looks like a swap router to me, but each service uses it’s own routers, and Im not familiar with all of them.

1 Like

I have the same issue
Did you get a fix yet ??

1 Like

I Did a swap for Slp to eth and transaction failed but my slp token was deducted
0x5aefc402523b9d8d18a3cb087dc5395bd4ace23da9f4ef95d8fe866b626bd50e

This was a failed swap.
“Fail with error 'ds-math-sub-underflow” can be caused by a few things, the most common cause I’ve seen is that the token your trying to swap doesn’t have contract approval for swaps. If approvals have been turned on, and you’re still having the problem.

Try reaching out to the DEX (like uniswap/pancakeswap) that is having the issue. They will be more familiar with the specifics of that token and how it interacts with their exchange.

Each transaction that is submitted has to be processed by miners. This is why the Ethereum network charges fees, even for failed transactions. Here’s an article with more details: https://metamask.zendesk.com/hc/en-us/articles/360045439051-Why-did-I-pay-gas-fees-for-a-failed-transaction

1 Like

@barmintea What is your ticket number? Ill touch base with Helpdesk and see if there has been any updates.

How do i get my slp tokens back in my wallet ??

This txn shows them being transferred out. Ethereum Transaction Hash (Txhash) Details | Etherscan

Was that an authorized transaction?

I just attempted a MetaMask SWAP between Ether & LRC. Ether was taken out and no LRC was returned. I have just counted over +50 similar issues in the community. How is this being addressed? Does anyone ever get their money back?

Mine is sitting in a Swap Server wallet. And I put in a ticket with MetaMask. Not clear how to troubleshoot…

1 Like

@barmintea did you ever get your coins back?

Hello @xemltil12345 , welcome to metamask community,

We are sorry you are experiencing this issue . Kindly provide us with transaction hash or public address so we can have our moderators look into it .

Thanks

1 Like

Thanks Stephanae!

Here is the Etherscan public Transaction Hash:
0xab247be4f3f0da727b2bff6009deab6f0b648d53281c8bfd18a649f403c9eec9

This was done as a MetaMask Swap & I hope it’s just sitting in a Swap Server wallet.

This actually looks like a transfer and not swap .

Please confirm if you recognize this address

0x235f9dca5246043878944821c9f60898446155F0

1 Like

I do not recognize that address. I did not send a transfer. I only initiated a swap ETH->LRC using MetaMask. I was hoping that the address is part of the MetaMask backend protocol for running swaps.

Did it indicate in your wallet transaction history that the swap was completed or a transfer was initiated to a different eth address ?

1 Like

Additionally, on my MetaMask app, that attempt at Swap is showing as if it occurred on April 15th, when clearly from the Transaction Hash on Etherscan show I made that attempt today. Something is bug with MetaMask on the Swap and how this is appearing on Activity.

More screen shot from details view of that Activity:

This clearly shows there was no swap initiated. It was clearly a transfer .

You have had seven transactions in this wallet so far and no trace of the LRC in the transaction history .

1 Like

I only tried to SWAP ETH to LRC today. And that is what I am saying, the SWAP took money like a transfer, and didn’t offer me the LRC in return. I never inputted that wallet. The wallet was autopopulated in the SWAP

The previous ETHER was used to buy BNB and REEF coin last week. I was only be on MetaMask for a week or so. This is my second attempt at SWAP.

Here is my same wallet address on Binance Network.