Metamask closes every time i want to sign a transaction

If I want to perform a swap on, for example, Uniswap, MetaMask closes automatically when I have to sign the transaction.
I’ve tried using settings Use Ledger Live on and off, but with both options MetaMask keeps closing when signing the transaction.

Does anybody knows how to fix this?

Thank you.

Greetings Erik

Hello Erik,
i experience the same issue on MM, after transaction is signed i see everything correct for 2 sec and then as MM as the browser will close down. I contacted support but no answer yet.
Could you find a solution to the Problem?

Not sure it was the same issue as mine or not.
Few days ago I had issues with my MiniMac + tried either Chrome or Brave + Ledger Nano X → everything is already in latest version(Ledger FW, Ledger Live, Browser revision) since i just downloaded everything few days ago. Note that i’ve set advance option in MM so ledger live is automatically ON during transaction.
Whenever I try to send any token out from MM(with bsc), it automatically opened Ledger Live then ledger live asked me to turn on my ledger. After i turn my ledger On with ETH app on, it just kept on rejecting from ETH app and asking me to open ETH app in ledger again, repeating like this forever. Transaction never been send out from MM to ledger for me to further approve. Process never been finished.

What i tried and recently works → I use Firefox instead. However, the problem with FF is i cannot enable advance setting in MM to automatically turn on Ledger Live(cannot access the icon). So this option is still not “ON”.
To continue, i manually access Manager option in Ledger Live. Then click on ETH to create account in Ledger live(even i’ve already had it). It will try to proceed to create ETH account until step3, then it just informs ETH account is already there, then stop.
After above description, i just continue to do transaction in MM as usual. However now the connection between MM and Ledger is successful. Ledger asks me to proceed as usual until approving the transaction, not reject me from ETH app in the middle like before.

Cheers

1 Like

Are you using Chrome? Have you tried using Firefox by chance?