Metamask doesnt show my FTM in the smart chain wallet

Im starting to think I lost my FTM. I sent it to my metamask adress through the BSC and I added the smart chain to my metamask wallet and after that I added the FTM token. It still shows my balance is 0. However if I go https://bscscan.com/ I can seer I have 199.5 FTM in my account. Does anyone know how I can fix this or did I lost my tokens?

Hi kerba18 try this :point_down:
https://metamask.zendesk.com/hc/en-us/articles/360015489031-How-to-View-See-Your-Tokens-and-Custom-Tokens-in-Metamask
Section :point_right: How to add a token using etherscan.io :roll_eyes: you use https://bscscan.com

Thanks for the reply but I tried that already aswell, it shows 0 FTM

OK I’ll send you a private message :slightly_smiling_face: for safety

I have exactly the same problem, did you find a solution?

Hi @Aacams :slightly_smiling_face:

kerba18 problem solved

  1. Connecting MetaMask to Binance Smart Chain
    https://academy.binance.com/en/articles/connecting-metamask-to-binance-smart-chain

Click :point_right: :gear: Settings - Networks - Add Network

Network Name: Smart Chain

New RPC URL: https://bsc-dataseed.binance.org/

ChainID: 56

Symbol: BNB

Block Explorer URL: https://bscscan.com

Click SAVE

  1. Click Add Token - Custom Token - your Token Contract Address is:
    0xad29abb318791d579433d831ed122afeaf29dcfe

Hey, Biiiiig thanks! It worked!