Metamask doesnt show my FTM in the smart chain wallet

Im starting to think I lost my FTM. I sent it to my metamask adress through the BSC and I added the smart chain to my metamask wallet and after that I added the FTM token. It still shows my balance is 0. However if I go I can seer I have 199.5 FTM in my account. Does anyone know how I can fix this or did I lost my tokens?

Hi kerba18 try this :point_down:
Section :point_right: How to add a token using :roll_eyes: you use

Thanks for the reply but I tried that already aswell, it shows 0 FTM

OK I’ll send you a private message :slightly_smiling_face: for safety

I have exactly the same problem, did you find a solution?

Hi @Aacams :slightly_smiling_face:

kerba18 problem solved

  1. Connecting MetaMask to Binance Smart Chain

Click :point_right: :gear: Settings - Networks - Add Network

Network Name: Smart Chain


ChainID: 56

Symbol: BNB

Block Explorer URL:

Click SAVE

  1. Click Add Token - Custom Token - your Token Contract Address is:

Hey, Biiiiig thanks! It worked!