Metamask not connecting

Something is wrong with my metamask, my NFTs r not showing on decentraland, i can’t connect to opensea where for the first time i am presented with this window, , i hope u can help asap thank you.

Hello, @Metou Welcome to the Metamask Community.
Is the screenshot from when you try to connect to Opensea?
What browser and version of the Metamask are you using?
Also, what are the steps you did try to connect?

Thank you:)! I am using MacBook pro Catalina version 10.15.7 , Chrome 91.0.4472.77 official build (x86_64) , and Metamask 9.5.9 the screenshots are when i first visit opensea before login in to metamask. After captcha is filled i login to opensea using metamask , i can see the opensea logo inside connected in wallet, but the page seems blank with profile and account beeing blank. The screenshots and not being able to login happened at the same time. Also in decentralsnd i am unable to load any NFT. I hope they weren’t stolen :pray: to connect i tried clearing history and cache , reseting metamask choosing another network like rinkeby , then going back to ethereum mainet network , changing accounts…i even uninstalled and reinstalled chrome.

Best regards,

Hi i tried again today ! I uninstalled chrome , installed firefox and having exactly same issues.
My NFTs r not showing in DCL nor in builder. I cannot login to opensea.