Metamask window blank, spinner and error

Hi, I’m using metamask 10.12.4 on Chrome & Firefox to approve an ERC721 transfer, and a spinner is displayed as soon as the metamask popup opens. I can see a warning/error in the console of metamask,

Uncaught (in promise) Error: Unable to determine contract standard
  at f.<anonymous> (common-1.js:7:379146)
  at Generator.throw (<anonymous>)
  at a (common-1.js:7:376936)

This bug has also been openned here, on GitHub] issues 14187
This is something introduced recently, because I’ve reverted to 10.11.3 and everything works correctly. Tested in Chrome & Firefox on 3 different machines.

Can someone please prioritize and fix this new bug introduced? Thanks, Daniel

8 Likes

Have you tried on a mobile device?

1 Like

Thanks for your reply, even if that worked, a vast majority of our client base (99%) will be using the website, so this needs to work on desktop. I’ve reverted back to 10.11.3 and it works perfectly, but we of course can’t ask clients to downgrade.

6 Likes

Ah, I see. I’ll inform the team and thank you for opening the GitHub issue!

4 Likes

Thanks for your support in raising awareness in the team, I appreciate it.

5 Likes

:+1: :grinning: :anguished: :angry: :nerd_face: :ok_hand:
its nice qustion

1 Like

Yep seeing this annoying error when interacting with this contract on opensea.

0xefabe332d31c3982b76f8630a306c960169bd5b3

“Error: Unable to determine contract standard” in the console.

Thanks :slight_smile:

1 Like

I am also experiencing the same issue, when trying to approve an ERC721 transfer on Metamask 10.12.4

Hoping For Quick Fix!

2 Likes

@danielh

It looks like GitHub issue 14187 you mentioned is related to an ERC-20 token transfer error.

Currently, ERC721 transfers should only be done on mobile. Here is more information on our Knowledge Base: