Metamask won't connect to any Web3 sites

Randomly out of nowhere MetaMask will not connect to any web3 sites. For example if I try to connect on Uniswap, where you would normally see a MetaMask button in the connect wallet UI, it now just says “injected.” Similarly on the Zapper UI it just shows “detected wallet.” Neither connect to MetaMask after clicking. This is the same across various RPCs. Have restarted computer, uninstalled chome, refreshed wallet, restored wallet with seed phrase and still no luck. Addresses associated with this MetaMask wallet all appear safu. Anyone ever seen this before?

5 Likes

Hey @ve1 , welcome to the MetaMask community! :fox_face:

Do you have any other wallets installed in the same browser aside from MetaMask? (Confirming you’re on Chrome).

Could you please also try changing the MetaMask browser settings so that it can change site data? You can do this by right clicking on the MetaMask extension> This can read and change site data > on all sites.

You may need to completely close your browser and re-open it for the process to take effect and for MetaMask to begin working properly again.

Let us know how this works.

Thank you!

6 Likes

Me, too. I was fine a few hours ago. Then it went wrong.

inpage.js:1 Uncaught TypeError: Cannot assign to read only property ‘ethereum’ of object ‘#’
at o (inpage.js:1:47063)
at r.initializeProvider (inpage.js:1:47463)
at Object. (inpage.js:1:1104)
at Object. (inpage.js:1:1165)
at 1…/…/shared/modules/provider-injection (inpage.js:1:1178)
at i (inpage.js:1:254)
at e (inpage.js:1:414)
at inpage.js:1:431

3 Likes

Hi @Tallone ,

Can you please provide information on the following 2 questions?

  • Browser / Browser version
  • Do you have any other crypto wallets installed/running on your browser?

Thanks!

4 Likes

I have exact same issue.
Everything was working perfectly few hours ago.
I use Chrome latest version: Version 106.0.5249.103 (Official Build) (x86_64)
I hope it can back to normal.

2 Likes

I checked again and found that it conflicts with another chrome plugin wallet “Frame Companion”. After disabling “Frame Companion”, the problem is solved.

But the strange thing is that this plugin is not newly installed, it has been installed before and has been without problems.

4 Likes

yeah it was my issue all good now. Thanks

3 Likes

@Tallone @chrouzz - can you share what version of MM you have installed? Thanks!

2 Likes

Actually resolved this. Here was the fix for anyone with same problem. I was running v10.19.0 on chrome. Looks like another wallet extension was preventing MetaMask from recognizing. Backpack (upcoming solana nft wallet currently in testing) was the culprit. All other non-evm wallets were not causing issue. I just removed the extension and it solved the problem.

6 Likes

This topic was automatically closed after 30 days. New replies are no longer allowed.