Pancakeswap stuck on approving contract

I’m trying to sell some coin I have but the contract will not approve to allow me to continue with the transaction. All other coins under V2 will also do the same thing, yet i’m able to still make purchases, just cannot sell.

1 Like

I am facing the exact same problem :sob:. Any news from your side? Or anyone else for that matter.

nothing. I’ve tried backing up my wallet and reinstalling it and moving it to another device but i’ve got no resolution yet

Hi, just a small update. I did try the “reset account”, it does work for some part :star_struck::
Settings > Advanced > Reset Account

I have managed to send coins from the wallet to another. I also managed to swap BUSD to USDT now (on pancakeswap).

However it doesn’t fix " Approving " issue for one coin (CAKE in my case), still stuck :sleepy:.

I just tried it and didnt have any effect. It’s so strange that I can still buy and sell tokens on v1 but I cant sell on v2. i can buy any token with bnb on v2 but when trying to sell or even convert FINE to anything else its stuck on approving

Hello, I do have the same issue, tried re-installation as well but coming up with the same stuck animation.

Same problem here, i tried to approve contract to swap and start to stake but the approve button on metamask app doesn’t work

Please fix this problem :confused:

were you able to resolve it, I am facing the same issue

Can someone from Metamask please advise on this issue?