PLS HELP ME can't access ethereum network and switch networks

Hi, I use MetaMask on Firefox (everything’s updated) and unfortunately I can’t switch networks: When I log in I can see only polygon mainnet. If I go to “settings” and “Networks” this is what appears to me:

If I click on “Ethereum network” I can see all the descriptions but I can’t change anything.
On the left in the main page there is a “?” where should I see all the networks instead.

Any advice?


1 Like

hi @jedihodler . My Firefox extension works fine.

When I log in I can see only polygon mainnet.

The screenshot shows that you have added many networks, can you send a screenshot of the wallet’s network list? Can’t you click to switch to another network?


I can’t see them if I click on the arrow. It says “MetaMask error” “Try again by closing and reopening the popup, or contact the support”. I tried again and again and it doesn’t work

got it. :joy:
Disable and then enable it in your browser’s extension management interface.
If it still doesn’t work, back up your seed phrase and try reinstalling.

Or wait and see if others have suggestions. :laughing:


This topic was automatically closed after 30 days. New replies are no longer allowed.