Recording voice in the Metamask native browser(android) not working

Dear community,

Me and my team are developing an dapp which allows the user to record their voice and mint it on the blockchain as an NFT. Everything is working fine on Desktop (using MetaMask’s extension), but the moment we try to test it (enable voice recording) on mobile (andoid) MetaMask responds with error “Error: no Audio”. Same error we had on Brave and Chrome before we allowed the app to record voice from the permissions menu, BUT MetaMask doesn’t even have that function.

We are very confused why and if this is a limitation. Would love to get feedback!
Thanks for your time to read and respond.

1 Like

Hey @eth, welcome to the MetaMask community! :fox_face:

Would you be able to send a screenshot of the error message?


Hi, yes no problem!

So this happens when the user clicks “Start” which will cause the app to start recording voice.

1 Like

Hi mate, any news on this? Thanks!

1 Like

Could this possibly be an error message from your android device, rather than from the MetaMask mobile app?

I highly doubt it since the same error was present on Brave and Chrome before voice recording permission was granted. When i checked MetaMask there is no such permission.

We did test it on multiple devices and the outcome is the same

Would you be able to contact our technical support team about this error?

You can do so at and click Start a conversation

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.