Send token showing as Submitted

I am not able to send any tokens to any address internal or external. The status shows as submitted. I have tried many times, all showing as submitted. Also I tried using pancake to swap the tokens, it is not going through. Also I tried to clear cookies/history everything and I uninstalled and installed again, no help. Also I tried another mobile, same issues. I tried change to custom ounce. Nothing working. Please help to resolve the issues.

hi @palaniselvam ,welcome to MetaMask community.

Since transactions on the blockchain will be queued, do not submit them repeatedly. If you have outstanding transactions, you can speed up or cancel it.
Check your activity on the blockchain explorer and if there are transactions pending, follow the detailed instructions in the article.


No pending transaction in the explorer. When I click the explorer. It says “ Sorry, We are unable to locate this TxnHash”. But in the wallet showing as Submitted. I have many wallet and tried few of the wallet and non went through.

Please try to clear account activity by following this support article and let us know if it works


I have followed the steps to reset the accounts. It works. Thank you for the quick response. Appreciate.


This topic was automatically closed after 30 days. New replies are no longer allowed.