Stakin swap in pool on trustswap, Fees paid, transactie succes but NO SWAP STAKED

yesterday i tried 3 or 4 times to stake SWAP in a farming pool on trustswap.

but no swap is staked,

refreshed browser, cleared cache, connected metamask again.

just tried again and still the same.

Then i tried to swap usdt from metamask account via uniswap for some extra swap. Got cancelled to!

AT THE MOMEMT I LOST AT LEAST 125 dollars in transaction fees, Last weekend allready had problems. Had a trustswap launch buy in: paid 502 dollars (should be 500) I paid 18 dollars transaction fee on metmask.
trust swap said i paid 517 dollars and i still see that i also paid the 18 dollars fee to Metamask.

So please tell me whats going on, because gas fees are out of the roof last days plus i;ve got at least 10 more examples of spended FEES WITH NO TRANSACTIONS MADE.

Please contact me @

thank you in advance!!!

Hi @Allard40 thanks for reaching out!

Please note we are opening a support ticket, I’ll be checking with you there via

Kind regards,