Strange error when trying to approve collection to sell on OpenSea

Hi there everyone,

when trying to approve an old collection to sell I’m getting the following error:

  • Message: Invalid data; should be ‘approve’ method, but instead is ‘setApprovalForAll’
  • Code: Error

Any help?

Thanks a lot!


Hi! Does the error look like this at all? [Bug]: Chrome setApprovalForAll function fails in Metamask for some collections · Issue #18507 · MetaMask/metamask-extension · GitHub

Can you please confirm what version of MetaMask you are using? You can find this out by going to your drop down menu > settings > about.



It does indeed look like that.

My version is 10.30.4

Does anyone have any idea on what the issue could be?


1 Like

Comment described here explains it and provides solution:


After reading through the solution a few times, I’ve managed to figure it out.

Thanks again both! :slight_smile:


I am also seeing this issue and cannot find a viable path forward, work arounds dont make sense in the latest MetaMask.

Does anyone know of any work arounds to the bug?

Someone has just responded to the issue:

Let us know if that works!


No luck unforately.

I get this when trying to invoke setApprovalForAll on this contract 0xfbeef911dc5821886e1dda71586d90ed28174b7d on etherscan or infact on any site which allows this change to happen.

When I click Write o try to trigger this, I get the following error:

MetaMask encountered an error
Try again by closing and reopening the popup, or contact support here.
Error details
Message: Invalid data; should be 'approve' method, but instead is 'setApprovalForAll'

Code: Error

Error: Invalid data; should be 'approve' method, but instead is 'setApprovalForAll'
  at a.getCustomTxParamsData (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-8.js:1:327461)
  at H (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-11.js:1:171446)
  at va (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-3.js:1:60111)
  at Mu (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-3.js:1:105038)
  at As (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-3.js:1:90901)
  at Rs (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-3.js:1:90826)
  at xs (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-3.js:1:88166)
  at chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-3.js:1:46516
  at n.unstable_runWithPriority (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-3.js:1:491157)
  at Qo (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-3.js:1:46225)
  at ti (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-3.js:1:46461)
  at ei (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-3.js:1:46396)
  at gs (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-3.js:1:84932)
  at Aa (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-3.js:1:63768)
  at chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-8.js:1:223704

I have tried the work arounds with no luck.

Any ideas on how to proceed?

Hey, I’m getting the exact same error.

I tried to approve KnownOrigin’s contract to be able to sell a KO token on their marketplace, but I think there’s some issues since they’re being treated as ERC20 tokens (the native KODA token), and not as NFTs - so MetaMask doesnt recognize the “set approval for all” thing.

This really sucks. I have tried removing the KODA in the “Token” tab (I have no “Assets” tab), and tried removing all the NFTs (I have 7 KO pieces), adding the 1 piece I want to list etc. But no luck.

I just updated my MetaMask, but I also had the error on the last version, but I haven’t updated my Chrome

Thanks for assisting me in this!


@jimbobbins @Norwegian

Please reach out to MetaMask Support.

  • This will connect you to a bot at first, answer some questions and it will open a ticket for you with an agent.

Remember - NOBODY, including from support, will ask for your secret recovery phrase or for you to input it onto any website for confirmation.


I am also getting this error. I have done the same as Norwegian.
Known Origin website says something about a KODA v1 and a KODA v2 contract. And under the contract I can see some people actually approving the SetApprovalForAll
I have tried all browsers and all combinations of adding the NFT
Following for updates

Hey @elekode, I would suggest contacting the support team with the link I shared above about this issue

1 Like

Crazy there is no solution posted after all this time. Seems like no one at MetaMask cares either, probably time to switch to Rabby wallet.

Here’s the way to fix it:
Go to your MetaMask wallet in your browser not the extension, go to swap tab, change networks to optimism then back to eth. Boom fixed, you are welcome.

1 Like