Unable to Swap on dapps

Yesterday, while trying to swap GMX for ETH on Arbitrum, I received an error message. Tried a different application and received an error message about an outdated router. Long short…I can’ execute swaps using MM wallet on MATIC or ARB chains on the extension. I can in mobile application. I have cleared cashe, cookies, etc… I changed browsers. I deleted Phantom. I uninstalled and reloaded. I put on a new browser with no other applications. Any idea’s?


Hello @BoopBie092583, welcome to MetaMask community!

Try changing the RPC url of the network or readding the network entirely.


Thank you but didn’t work. It’s really weird. Now I can swap on Uniswap but not stable coins. Can’t swap on another dex at all.

Update. Problem I think is resolved. Craziest thing. I’m working remote and working with a scheduler and would let me schedule in the past. Changed my clock. This seems to have screwed with something. Randomly, I thought of this evening and sure enough when I changed back to local time…worked.

Hey @BoopBie092583, glad it’s working again!

Can you explain more about the error you got? Do you have a screenshot to share? It would help to know more about this issue in case other users may have this issue with changing the time on their device.


I really didn’t get any descriptive error messages. There was one application, Camelot, where the message came back with some text about the router was outdated. In hindsight, that was the only clue. Must have been some disconnect in the pricing oracle. I’m not a tech person so I really have no idea. Just that when I corrected my laptop clock to my current timezone, I had no more issues. Sorry I’m not more of a help.

This topic was automatically closed after 30 days. New replies are no longer allowed.