USDC didn't come through from Binance

Hi everyone, I need help.

~11 hours ago, I tried to transferred 100USDC from Binance to Optimisim via LayerSwap (powered by Bransfer). The transaction got through but I couldn’t see it neither on Optimism (which was connected to my Metamask) nor on my Metamask wallet (I tried adding the USDC token and changed networks to BSC mainnet and BSC Testnet but my USDC still showed up as $0).

Here’re the info:

  1. The transaction shows up on Loopring (Account #113842)
  2. Metamask address: 0x520e805e3c91c5a047c67e589476884587978fd1
  3. On Binance, I transferred through BSC network and the destination is: 0x809144797b02c01830298124cb3126d9194c80dc (it shows successful on my Binance - transaction history)
  4. On bscscan, I couldn’t find the transaction above though

For the 3) above, I remembered I put my Metamask wallet address (the one in 2)). But I don’t know why when I checked the history, the address changed to the one in 3). Maybe cuz I chose the BSC network and that caused the changes.

I’m confused and are eager to learn more about what I’ve missed. I did it last night when I was very sleepy… maybe that’s a lesson for me too!

Appreciate all your help!

I also tried adding the destination address shown on Binance to Metamask (where I added Smart Chain network and pasted it under “Token Contract Address”), the balance is still 0.

That means you were not using the bep20 network to transfer money.

I used BEP20.

Anyways, I just want to see and use the USDC. On Loopring, i can see the USDC was deposited to my metamask wallet address successfully. But how can I use and see it in my metamask? My next goal will be to use the USDC to bridge to Hop Exchange but now I cannot utilize it…

Much appreciated!

problem solved. I went on to Loopring and “withdraw” my USDC to my L1 address then it showed up on my metamask. The fee is not cheap though (35% for 94USDC).


This topic was automatically closed after 29 days. New replies are no longer allowed.