xDai chain balance stuck on "Eth"

I have been successfully converting Dai to xDai using the xDai Bridge (https://dai-bridge.poa.network/) but I accidentally sent Ethereum from the Ether main net to the xDai chain and now my xDai chain format seems to be stuck on Eth (it correctly shows $13 but displays 0.0075 XDAI).

Now I can’t use the xDai bridge anymore (but it keeps charging me the main net eth fee) and the low xdai balance doesn’t allow me to move my other assets to any other wallet. Please help! I would really appreciate it.

Welcome to the MetaMask Community @jamhausen!!

I apologize for the trouble with your wallet. For your privacy & security, and so we can assist you in investigating further, I’ve created a support ticket for you.

Thank you for your patience.

1 Like

Hi @jamhausen , you might want to try removing xDai from your custom network list and then re-adding it. It sounds like ETH was accidentally entered as the base asset instead of DAI, or something like that.

I tried this but it didn’t work.
I also tried sending some of the 0.0075 xDai to another wallet (hoping it would reset it) and it said “confirmed”, charged the fees, and I never received the xdai on my other wallet. Very frustrating =( please help!

Are you sure the xDai chain was added as a custom network on the wallet you sent to?

I sent it to my Trust Wallet address and manually added xDai’s contract address from coinmakertcap. it shows 0 balance.
The gas fee was definitely charged, just like the gas fees from when I attempted converting Dai to xDai through the bridge (and failed).
I contacted the bridge’s support but they say the error is coming from the metamask side. Not sure what do try next.

If you sent the funds to TrustWallet, it sounds like TrustWallet isn’t correctly configured to connect to xDai. I’m actually not very familiar with TrustWallet, but it definitely sounds like an issue with that wallet. I’m not even sure if TrustWallet supports xDai? If the funds left your MetaMask wallet, the issue wouldn’t be with MetaMask.

Well, I was having this problem before I involved any other wallet, so let’s leave trust wallet out of the equation.
When I connect my Metamask account to the Dai-xDai bridge it shows my balance in “Eth” instead of xDai. I’ve tried several times to convert dai into xDai in order to have enough gas to move my other assets but it keeps charging me the mainnet eth gas fee and the funds never arrive. Considering there’s no other wallet involved but just 2 networks withing Metamask, it suggests it’s an internal problem.
I know I’m repeating myself but I’m going from frustrated to sad.