Account tick box greyed out in "Unlock Trezor/Select Account" screen

See how acct 2 is greyed out? I cannot select or deselect it to use this Trezor acct in Metamask. I have used this account before but after some usage, this box gets greyed out? Does anyone know the cause? Clearing the cache does not help. I have to disconnect Trezor, close Brave, and start again to fix it.

Hello @Ian444 Welcome to the Metamask Community.
Make sure you are using MetaMask on the primary screen of your computer (not extended display). It’s could be a weird UI issue extension experience.

I did use my primary display.

I have the same issue

Since 1-2 weeks having the same issue.
Also when trying to connect to a site the last connected account is used.
Only help is to “remove account”

Yes “remove account” that can work too, I forgot to try that last time. Reloading all the custom tokens in the wallet is a bit of a pain though after doing that, or anything else like that. A few times I uninstalled and reinstalled MM and that fixes it for a while. Some things I tried only work sometimes. I’ll try the new version MM (supports multiple hard wallets now!) and see how that goes.

I think the last version causes the problems as it occurred in the last one/two weeks.

Have you previously imported that address/account to your MetaMask wallet? Which Trezor are you using? What’s the firmware version? What version of MetaMask are you using? What device and browser?

I see you’re currently on the BSC network. If you change your network to Ethereum Mainnet prior to connecting your Trezor, do you still have this issue?

I want to try to reproduce this. Thank you!

I’m using Ledger but experienced the same problem. I circumvented the problem by using Ledger Live to access my tokens.

I’m using Ledger Nano X with the last firmware version, latest ETH app installed, with Metamask with Opera and Firefox portable without Ledger Live. Had it on the Ethereum Mainnet and on xDAI Chain when trading on Honeyswap.

Yes I’ve been using that account for some time. Using Trezor1 with latest firmware updated very recently. I have 2 laptops, one is Win7 and the other is Win10, both show the issue in the screenshot.

I have upgraded Metamask yesterday and haven’t seen the issue arise so far. If I do, I’ll try changing the network to Ethereum Mainnet prior to connecting the Trezor.

I’ll also try to write up some steps to reproduce the issue, it does appear to be a bit random as sometimes I can do a few transactions and others only one. There also seems to be difficulties elsewhere (may be related) in that sometimes when Metamask sends the transaction to the hard wallet to be signed, the signing action is not engaged with the wallet and the transaction is left hanging. Other times, when the Trezor page comes up to secure the Trezor, I see a notice saying that the device is being used by some other app, and other various notices.

If I see any issues again I’ll report back, but hoping all is good now with the new Metamask version.

I started playing around with it to see if I could reproduce, this was all done using Ethereum mainnet only.
Steps to reproduce problem:

  1. install metamask

  2. connect Trezor1

  3. go through the trezor1 login process

  4. select account you want to use

  5. all good to this point

  6. disconnect wallet from PC

  7. reconnect wallet to PC

  8. click on “Connect Hardware Wallet”

  9. screen with greyed-out box is displayed

  10. restart PC

  11. open Metamask and enter password

  12. connect Trezor1 and click on “Connect Hardware Wallet”

  13. screen with greyed-out box is displayed

It seems the only fix now is to reinstall Metamask. Is it possible to download an older version of Metamask to compare the behaviour? As someone else mentioned, it only started happening in the last couple of weeks. I’m not convinced it’s actually a Metamask problem, there could be many causes - other updates, Trezor Bridge driver, some MS thing, who knows… Is there some kind of log generated by Metamask that would help troubleshoot? I also tried disconnecting the Trezor, disabling the driver, re-enabling the driver, then reconnecting the Trezor but that didn’t do anything.

UPDATE: I found that by switching to a Ledger, it connects, but it is also capable of displaying the greyed-out box. But I found a work-a-around, in that when the Trezor is reconnected, there is no greyed-out box until disconnecting from the PC and reconnecting…

1 Like

I got a log of related error put by Metamask, using a Ledger, could not attach file so I’ll print it out here sorry.


Error Details
Message: Cannot destructure property ‘name’ of ‘m[B]’ as it is undefined.

Code: TypeError

TypeError: Cannot destructure property ‘name’ of ‘m[B]’ as it is undefined.
at Function.C.balance [as mapToProps] (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui.js:152:759276)
at n (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:93:20755)
at Function.n.mapToProps (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:93:20891)
at n (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:93:20755)
at chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:93:19596
at chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:93:12990
at Object.useMemo (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:75:63534)
at useMemo (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:136:5250)
at _ (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:93:12934)
at ca (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:75:59367)
at Ga (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:75:67589)
at Va (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:75:67408)
at Ua (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:75:67127)
at jl (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:75:107861)
at bu (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:75:90053)
at pu (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:75:89978)
at iu (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:75:87326)
at chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:75:45768
at r.unstable_runWithPriority (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:172:3472)
at Vo (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:75:45477)
at Yo (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:75:45713)
at Ko (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:75:45648)
at au (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:75:87618)
at Object.notify (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:93:24588)
at e.t.notifyNestedSubs (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:93:24155)
at e.t.handleChangeWrapper (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:93:24223)
at b (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui.js:137:63254)
at chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui.js:137:57230
at dispatch (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui.js:137:59495)
at chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui.js:152:1332886
at Object.dispatch (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui.js:137:57221)
at Object.dispatch (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui.js:137:77672)
at i. (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui.js:152:1338548)
at f (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui.js:59:21106)
at i.emit (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui.js:59:24092)
at sendUpdate (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui.js:1:13143)
at u.apply (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui.js:72:61725)
at u.handle (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui.js:72:61423)
at i.handle (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui.js:72:65116)
at i.write (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui.js:72:65021)
at s.m (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui.js:137:23642)
at f (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui.js:59:21106)
at s.i.emit (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui.js:59:24092)
at w (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui.js:137:18447)
at _ (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui.js:137:18262)
at s.y.push (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui.js:137:19073)
at t.exports._write (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui.js:113:214850)
at y (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui.js:137:31429)
at chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui.js:137:34607
at t.exports.v.write (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui.js:137:3

Thank you for providing all of this @Ian444!

I want to highlight your workaround:

UPDATE: I found that by switching to a Ledger, it connects, but it is also capable of displaying the greyed-out box. But I found a work-a-around, in that when the Trezor is reconnected, there is no greyed-out box until disconnecting from the PC and reconnecting…

We’ll continue to investigate this on our end for a resolution to this issue.

I have the same issue. If a checkbox is checked, then it’s grayed out and can’t be unchecked. But any checkbox that is not grayed out can be checked and unchecked. But if I check an unchecked box and leave it like that, the next time I open MetaMask that box is permanently grayed out as well and can nom longer be unchecked.

Now I have five accounts with grayed out checkboxes, but interestingly, they are now all available to choose under ‘My Accounts’, which is great. In the past, I could only have one account ‘active’ at a time. But I don’t want all five in the list, but two would be great.

Also, I connected a second Trezor and once I chose one account and left that page, when I came back the checkbox is now grayed out as well. Disappointing. I had hoped that switching Trezors would reset everything.

I see that someone mentioned the Binance Smart Chain. I have recently added BSC and Matic chain to MetaMask. Perhaps there is a connection?

That is an interesting observation, as it is quite possible that my issues started happening around the same time that I added/started using BSC.

So far, my easiest work-around is to remove the offending account and reconnect.

Just an update - the grey boxes persist, but the workaround quoted above is working fine. I can still trade so all is well :slight_smile: