Problem with my metamask linked Trezor One

Dear friends, I need your help. I have linked Metamask to my Trezor One. However, the wallet linked to Metamask is not appearing in any accounts in my Trezor Suite. Without realizing it, I transferred my money to this “new account” linked with Trezor One. Now I can’t move my assets because when performing the sending procedure, when enabling with my physical wallet, Metamask closes before completing a transaction . Do you have any suggestions on how to resolve this? I tried on Trezor support but they didn’t want to help me.

4 Likes

Hey @hpornelas, welcome to the MetaMask community! :fox_face:

Your MetaMask accounts should not actually show up on your Trezor. Here is some more information on our Knowledge Base:

To clarify the situation, you have sent tokens to your Trezor account by mistake and you would like to transfer those tokens out? You would need to sign the transaction on our Trezor wallet.

Dear @nakedwinnie many thanks for the answer.

Sorry I think I was a little bit confuse when I try to explain myself I will clarify my question:

I already have tokens in my metamask witch is linked into my trezor wallet, but the account is not showing inside my trezor suit. The problem is when I try to send my tokens witch is inside my metamask-trezor to another account. Before the transaction start the metamask close by itself and inorder to open again I need to close the google chrome and get in the metamask again with my password etc.

For your account not showing up on Trezor Suite, I would try contacting Trezor again for the issue. Sorry to hear their support did not help you, but maybe try again and see if you get a different response?

Have you tried restarting your browser or using a different browser?

Dear @nakedwinnie I have tried to

I have tried to retrieve my metamask and trezor accounts using both seeds in different browsers but my metamask account linked to trezor doesn’t show up on both performed inputs.
do you know if there is any way to recover my access to this specific wallet using my passphrase, seed and public key? I have all but I don’t now the way to recovery it

Your Trezor account will not show up when you recover your MetaMask wallet with your Secret Recovery Phrase because it was an imported account connected through the hardware wallet, and not actually a part of your MetaMask wallet. You would have to connect your Trezor wallet to your MetaMask wallet again.

Your Trezor account is part of your Trezor wallet which can be recovered with your Secret Recovery Phrase.

1 Like

Thanks so much.

I have tried to connect to my trezor wallet but my address which is connected to my metamask it is not showing up between all the trezor addresses offered to me. This trezor wallet address is not showing up in my trazor suite and I just can see it from my old metamask account but there I still can not move my asset even after do the manual metamask upgrade from the 10.7.1 to 10.8.0

Try turning the passphrase option on your Trezor on/off, and see if that helps. It may also be that you are inputting the seed phrase for another Trezor wallet, which may be why your account is not showing up.

Hope this helps, just going off of some of the suggestions here:

1 Like