Can’t find hardware wallet after uninstalling metamask

Hi

I connected my trezor wallet to my metamask account and transferred all my funds into this account.

I was having trouble trying to stale my Olympus tokens so I uninstalled the metamask on my browser and reinstalled it.

After that I recovered my account and I can’t get my hardware wallet back. I have tried all the suggestions on these forums but no luck.

I can’t find the eth address when I connect the trezor to metamask. I can see the funds in etherscan.

I can see this is a problem a lot have had but I see no fix. Please someone help me get my money back!

Hey @Navt, welcome to the MetaMask community! :fox_face:

No need to worry about your money being lost, it’s still in your Trezor and you can access your addresses through Trezor Suite :slight_smile:

Have you tried turning the passphrase on/off? This thread may help you:

Here is some more information on our Knowledge Base that may also help you:

Hi

It is not in trezor either.

I have followed every single forum online and I can’t find it any where.

I spend about 10 hours following everything.

Please help me as it was a lot of money I can’t access

Sorry to hear the issue still continues :frowning:

Please contact the Trezor team as this issue relates to a missing Trezor address. Hope they can help!

I have contacted them as well.

I am hoping metamask can help locate it as well.

I have reached out and put a ticket in. I can see in the forums a lot of people have had the same issue I am currently having.

I have the address and the funds are there when I check the address online. I just need it added back to metamask