I've lost my metamask hardware wallet

I was so excited to use my Trezor Model T to set up a hardware wallet and connected it to my computer. It was set up fine I just didn’t remember if the wallet is set up hidden or just the regular one without a passphrase. Moving on, I successfully created a hardware wallet and transferred all my coins to my hardware wallet in metamask. For some reason i removed my metamask from Google chrome and tried to retrieve it using my metamask seed phrase. All the metamask account were there except for the hardware metamask which is linked to my trezor.

I tried to create a new account but I couldn’t find the ‘Account’ or “Contract Address” that i picked before to retrieve my funds. I still have the account that is provided by Trezor and I can still see it in bscan, but i can’t retrieve that so i can see my funds in metamask.

Hi there. To see the hardware wallet again, you will need to import it again as it it’s not linked to your current MetaMask or secret recovery phrase.
https://metamask.zendesk.com/hc/en-us/articles/360020394612-How-to-connect-a-Trezor-or-Ledger-Hardware-Wallet

2 Likes

have the same issue is this already resolve?