2 separate issues metamask extension

hi
issue no 1- i have 3 wallets on my metamask extension and i am trying to secure them with a ledger -i have only successfully secured 1 wallet as i i cannot find the other wallets on the list -even scrolling 200 wallets down in both categories as advised

issue 2 -i tried a work around and tried to import the wallet to firefox -now my main wallet doesnt show up at all even after creating additional 6 wallets it doesnt show up
i also tried on my phone and my main wallet doesnt show up either
it has the same secret phrase as the others but doesnt show up

could someone help as i would like to secure my accounts
thanks

1 Like

Hey @reilly110, welcome to the MetaMask community! :fox_face:

When recovering your accounts, please make sure you are inputting your Secret Recovery Phrase correctly.

Here is some more information on your Knowledge Base:

the secret phrase is correct as it works for my 1st wallet but but 1 wallet does not show up as i said above -my only thought on issue 2 is that that wallet is from years ago and i dont have secret phrase or keys for it -what is best option in that instance ?
also i checked in the mnemonic-account-generator
and the wallet doesnt show up in the top 25 wallets

as with issue 1 -any ideas /
thanks

any idea with issue 1 - i have tried to secure with new trezor and it still cant see my metamask accounts to link up -so this is is definately a metamask issue
please help thanks

If I am understanding you correctly, are you trying to connect more than one account to your Trezor? Only one account can be connected at a time.

Please refer to this article on our Knowledge Base for more information:

im trying to connect 1 account at a time -but cannot find the wallet address when i do this

1 Like

If you have inputted your Secret Recovery Phrase for your accounts correctly, you should be able to access them by creating accounts within the same wallet.

i know how to create accounts - this is not working
i have 2 big issues and no “knowledge base” has helped