The seed phrase has not been restored to my original account

The story is: I bought a Blok token on Kucoin to invest in Bloktopia. Since all the slots were full, I waited until I could again. When it was announced that it was available again, I found out that MATIC was charging a fee, but unfortunately, Kucoin had closed transfers for weeks due to server maintenance. When the block was lifted, all the slots on Bloktopia were full again. By then I had already transferred my blok tokens and MATIC from Kucoin to MetaMask. I was sure they were safe and would not be hacked, so I left them in my MetaMask account. When I was again allowed to reinvest the blok tokens, MetaMask did not show the balance in my account.

I then tried to solve the problem as described and finally reinstalled MetaMask. Since then, I have not received my account ending in B37a7 back, instead, I have received the account ending in f371. No matter how many accounts I open, B37a7 is never listed.

The descriptions available do not help me to access my account either.

  1. danfinlay.github does not show my wallet. (B37a7)
  2. I checked the MetaMask Decryptor.htm for the associated secret recovery expression. It has exactly the secret recovery expressions I described to myself, and in the order I described.
  3. On AstroGrep, I looked up ","salt!*, but instead of (vault":“, I have it starting with: v�U”:"{\��Ua":\ and I don’t know how to fix this so that MetaMask Decryptor.htm will read it.

I couldn’t solve it by myself and can anyone help me with this?

7 Likes

Hello @Herufer, welcome to MetaMask community!

Please check the following article for a possible solution to your issue, if you are certain you have the correct SRP for that respective address, and let me know how it went.

4 Likes

Thanks, but I tried about twenty-five times and it didn’t help.
Every time I reinstall MetaMask and then import the accounts, the lost wallet is never listed. If I just import the Blok token, it doesn’t show in the account. It’s practically no good at all.

3 Likes

The account you are referring might be an imported account, not the one contained within the Secret Recovery Phrase you have. Have you made sure you have all the information you need saved and can look for where that address might be stored from?

2 Likes

Not imported. I also checked on Kucoin, I may or may not have returned it, but the contracts say it’s on the MetaMask wallet. I currently have the wallet, the balance has both Blok tokens and MATICs in it. I have connected it to Blokpad alone, but have not been able to invest.

2 Likes

When I did the MetaMask wallet, I had three accounts. The public address of one of them was 0x00a6b559241cb881c0ac840fa8fa945277B37a7 and when I reinstalled and made three accounts again, it was not listed once. Instead I got a wallet like this: 0x9922fba64b70de24d947b7123900013aaf2f371

Hi @Herufer. Did you follow the instruction described in this link with video explanation ?

https://github.com/MetaMask/metamask-extension/issues/3127#issuecomment-1072775852

Or this one on PDF file ?

https://github.com/MetaMask/metamask-extension/issues/3127#issuecomment-968261070

About your question

just replace v�U":"{\��Ua":\ by {"data":"

If you found the expression ","salt!*, most probably it is vault of your right seed phrase for the lost account.
:crossed_fingers:

4 Likes

I’m glad you’re here! I’ve been reading, yes.
I just got stuck on this: v�U":“{\��Ua”:"Zhk5TE…
So, the {“data”:" insertion should be done like this? Because I still don’t understand.
v�U":“{\��Ua":"Zhk5TE… —> {“data”:"Zhk5TE… or,
v�U”:“{\��Ua":"Zhk5TE… —> {“data”:”{\��Ua":"Zhk5TE…

Because it’s still not doing anything.

This version is right. Only be sure you have {"data":"Zhk5TE…
Difference is in oncoding of quots:
image

The whole data to decrypt should look something like this:

{"data":"wwpXXtFCqZkYsWfeEwItZjJ0Cc7mRVjG47Dqh+ztL1PiCG6Izhg+zG0mM+H2ykyjz3X0RNhAE6IVsWFZamcZ47B4sVi4SvUxrMhARm5L3yHPxr3UsyGrOXmthyVMgEGmjwlmnFCNd2nMZ2o8/sRMra8FupurqevnBv57FiYpEEs7gPpFHv6587aL44MmKD8Snv4JLFqiqmlK82Waq5F+Iv9mw2sFVAL9mgZBSgFgbWdB3TsKVB2k","iv":"rkUQlNcGTxBE0My7a/bCXw==","salt":"HcKyNfGzaRALRQ0DlKgcIe5Uk30iI/M//oG6w8vX8Nk="}

Also make sure your ","salt! is correctly modified by ","salt":"..... like in the example :point_up_2:t2:

3 Likes

You forgot this, but it works now! As usual, it shows the secret recovery terms, Ledger Hardware and “bridgeUrl”:". What do I do now?

2 Likes

Is the secret recovery phrase is your usual one ? :thinking:

1 Like

Yes! The secret recovery phrase is the same, and the order is what I wrote down myself.

1 Like

Ok, I see. :frowning_face: It is not a vault data you are looking for, then. I would suggest you in this case to follow these instruction:

https://github.com/MetaMask/metamask-extension/issues/3127#issuecomment-1072775852

:crossed_fingers:

6 Likes

I got an external hard drive, followed the instructions and videos, and did what I needed to do. I found twenty files with .asar, .js, .ldb, .log, .cat, .dll extensions. I searched through it, but there was no different address. All {\data": identical characters, and no anomalies according to MetaMask Vault Decryptor.

I have no idea what is wrong.

2 Likes

While using Recuva, did your search word was \"salt (without !) or \"salt! (with !) ?

5 Likes

Just "salt … I didn’t use an exclamation mark.

2 Likes

Wrote you an answer on GitHub as the message here didn’t get through for some reason

Im having the same issue, I had to restore my MetaMask account by providing seed, all these accounts were created under he same seed, Account 1 my first account and Acc 3 ,4 restored Acc 2 and 5 were missing, I manually added “create account” and then acc 5 were added but acc 2 was still missing, I again createed account but acc2 was never restored… now Im acc 13 and still not coming up… how is this possible?

Also to provide some background, I tried to create a burner wallet on a different browser,mozilla the first time. (I always used my main one on chrome and never had to restore ever) I created it on mozilla but then somehow it started interacting with chrome and when I was still logged in on mozilla with my newly created wallet,it didnt let me log in onto chrome to my old wallet… so then I had to restore my original wallet in chrome (I removed the extension from mozilla) because it only let me log in with the new wallets password on chrome too. Its also weird that Account 1 ,3 and 4 came up when I restored the wallet with seed and acc2 and 5 which didnt have eth on eth mainnet didnt come up and had to manually “create account” and then acc 5 came up but acc 2 never… all these were created under same seed in chronoligical order so thats why I dont understand how its possible that acc 2 didnt show up…

I’m having the exact same issue. Had to reinstall my mobile app today due to storage limit issue. My account 2 (no eth either) did not show up when “create new account” in attempt to get my previous accounts to populate. I got a response from a tech support which was just copy and past of available links. Not helpful at all. It appears that others have had the same issue who have not got any kind of resolution.