Avalanche curve.fi swap stuck, don't know why

Hi I’ve made a transaccion in an avax .curve .fi pool and got stuck for more than a day.
I’ve tried the three methods that I know:

  • Speed up transaction
  • Cancel transaction
  • stepping over the corresponding nonce.

But still I can’t get that transaction out of the queue.

It still says:
RPC Error: [ethjs-query] while formatting outputs from RPC '{“value”:{“code”:-32603,“data”:{“code”:-32000,“message”:“replacement transaction underpriced”}}}

Do you know any other way or what is happening?

Hello, the problem of blocked metamask transaction has been bothered for some time. At present, there are several ways to solve it: 1. Download the mobile version of metamask, import it into the mobile version with your private key, send an asset to your other address in the avax chain of metamask on the mobile side (you need to manually add the avax chain), return to the PC side after sending, restart the browser and log in again, and your problem will be solved.
2. You can switch the ETH chain and avax chain back and forth in the plug-in wallet of metamask, and the switching interval is 2 minutes. This method works occasionally.
3. Accelerate the transaction and maximize the gas cost in customization. However, this method is not recommended because avax gas is relatively expensive. This method is generally only used in polygon chain.
The above are all the solutions to the problems you mentioned. I hope you are satisfied.


This topic was automatically closed after 30 days. New replies are no longer allowed.