Replacement fee too low - Avalanche

Hi There

I’ve searched this topic in the threads and have tried all the suggestions to fix but no luck so far. My error only occurs on my Avalanche network / not any other

I’ve increased gas/priority/gwei by 10% to even 50%

reset/reinstalled my metamask

tried sending myself a transaction to overwrite nonce

i did recently change from a private endpoint back to avax’s rpc

there are NO pending transactions according to snowtrace

“Swap failed: replacement fee too low (error={“code”:-32603,“message”:”[ethjs-query] while formatting outputs from RPC ‘{“value”:{“code”:-32603,“data”:{“code”:-32000,“message”:“replacement transaction underpriced”}}}’"

Hey @0xUptake, welcome to the MetaMask community! :fox_face:

Thanks for searching through other threads about the same issue, seems like you tried several different things, sorry to hear the issue still continues.

If you would like, you can submit a ticket to our support team at and click Start a conversation

This topic was automatically closed after 30 days. New replies are no longer allowed.