Unable to cancel, replace or speed up transaction

Yesterday I was trying to replace a transaction where I’d set a too-low gas fee. I’ve done this successfully numerous times in the past but yesterday it was not working (I’m using MetaMask in Chrome with a Trezor One). I clicked ‘Speed Up’, increased the gas and gas limit, but the old transaction was not being replaced. And when I looked at my address on Etherscan, it was still the same transaction pending there with the original low gas fee.

I then created a new identical transaction with the same nonce, but after it was ‘successfully’ sent, the old transaction was still showing on the blockchain and wasn’t replaced either. I also tried to send a replacement transaction with the same nonce from another browser but that transaction just failed. I did this twice.

Luckily the gas price came down a few hours later and the original transaction went through. After that, I was able to do other transactions without any issues.

If anyone knows how something like this could happen, I would appreciate it if you could share it. It was extremely frustrating since this particular transaction was very time-sensitive. If the gas price hadn’t come down after 6h to let the transaction through, don’t know what I would have done. Thanks.

1 Like

Hey @don911, sorry to hear you ran into this issue, and glad to hear that you have solved it.

In terms of why it happened, there could be several reasons a transaction is stuck pending and having issues being sped up or canceled. Here is more information on our Knowledge Base:

1 Like

I had the same problem and tried everything I could to get mine to go through. I placed a ticket request for support. I rcvd no reply on the request. Other than referring me to the web site were i got 3 messagges on the first 3 days. One of which was to reset my wallet. I tried to get it unstuck for 6 weeks. I exhausted ever suggestion i found on the internet. I final reset my wallet. Now I have lost $2500 of AVAX. It is a recurrent problem and the programing glitch needs to be corrected. If the programing has issues metamask needs to fix it because this is complete BS.

Hey Fatman,

How did you lose the AVAX through resetting the wallet?

I reset the wallet and the transaction is no longer active. I have a screen shot. Of the transaction. The trasaction stalled and i was out of gas. I attempted to send myself more for gas fee but i was never able to get the funds to transfer. I was recieving Json-rpc error. I had tried everything i could find on line. I never got a response from Metamask support. I did get suggestions from other users. I tried multie tomes. I had exhausted all suggestions. Except the reset your account. I reset my account and the only AVAX ($15) I had was in the wallet and transactions were gone. $2500 worth. I had sent a test transaction prior to the large transaction. The test completed without incident.

Hi Fatman,

You can’t lose funds when you reset a wallet. Can you share the public wallet address where your avax was?


Hi Fatman,

When I look at your transaction history on Avalanche explorer for wallet 0xadaf2f191da8947153d634aff3fddb452bb20777 it looks like your balance shakes out. You do have some wrapped avax in that address, just confirming you know that and have it added back in this wallet.

Is the email you received re: your MM ticket from you using the live chat option here? I don’t work for MM so just curious if that’s the flow. If not, you can use the live chat option too? At first a bot responds but after you respond a bit you get an agent.

Lastly - goes without saying probably but since you shared a bunch of info here in screenshot be careful of scammers. They now have your MM ticket number. I’m sure you’re on top of it but figure it never hurts to say it.

The transaction is stuck and did not complete the transaction to Thor Financial. I was unable to add Avax for gas to complete the transaction. I changed the nonce number would attempt to send it. I repeatedly got the json error message. I was also getting an error to add more ETH even though I was on the Avalanche Network. I appreciate you taking a look at this for me. My MM wallett has very limited funds because i most likely will not use it anymore. My $2500 lesson kind of turned me off. I never recieved any reponse from customer service on my ticket. If you can think of anything else I can try please let me know.

It is a miracle. I complained that I had no response to the ticket I had submitted to MM. At 1410 I received an email from MM and they want to address my issues.

1 Like

Hooray!! I’m glad to hear this. I think they’re really trying to ramp up support but if you look at how fast they’ve grown over the past year, I figure there is a wait sometimes.

About a year ago I waited a while for a resolution to something but I can say hands down the team that worked with me cared about getting a resolution, and came through!

Let us know how it goes, figure it’s something I can use as a learning opportunity for myself if you’re willing to share.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.