Stuck transaction, I can't replace existing transaction

Hi so my issue is a bit complex. I performed a testnet transaction on geth and it was pending, after some time I tried to speed it but it didn’t work, then I tried to cancel it, it still didn’t work.

Then I figured the transaction was stuck because it wasn’t even showing on testnet etherscan. I tried the whole clearing of activities and nonce from the advanced settings in MetaMask but after clearing it, when I try to perform a new transaction, it keeps saying “CANNOT REPLACE EXISTING TRANSACTION”

Please how do I fix this?
Here’s the wallet


hi , see if this works for you


Hi, thanks for your response but that doesn’t work for me. The transaction hash isn’t reflecting on etherscan and also I already cleared my MetaMask activities but since the transaction isn’t reflecting on etherscan, I feel maybe it is stuck

This is the error I keep getting.

1 Like

It would be best if you contact Support team at and click Start a Conversation


Once you click Start a conversation a live chat bot will appear on your screen. It will give you an automated response at first, but afterwards you should be able to contact the support team


You need to clear your account activity and nonce data in your MetaMask Settings, under Advanced option.
For more information, please refer to the following article.


I already did this but still when I try to perform another transaction, it still says “I can’t replace existing transaction”

1 Like

I clicked the “Start a conversation” and it says connection unavailable

For most, the button should fully load and be clickable within a second or two.
If it won’t load, it could be that your browser’s adblockers, or similar applications, are interfering with our back-end. Try disabling them for the Support page. If all else fails, try using a different browser.


I started a conversation with the bot then it showed the connection unavailable again.

But when I clear my activities and nonce, do I need to wait some time before I can make another transaction?

Is there a way I can check my pending transactions nonce in etherscan because I already cleared my MetaMask activities and nonces

Your wallet has no pending record on testnet etherscan and I also don’t know where to check it, sorry. Hopefully the support team or someone else here can help you.

When you have no other options, consider resetting your wallet. The premise is that you have backed up your Secret Recovery Phrase and private key.


This is the error I keep getting

Gas prices on Goerli are very high at the moment and that could be the issue. Are you sure your pending transaction is still pending? It may have been marked as failed now.


Why do you want to replace an existing transaction? That I suggested to clear your account activity was because the transaction data wan not seen on the Goerli Etherscan. In such cases, only clearing the nonce data suffices.
In summary, based on your account activity, you do not need to replace an existing transaction. Just clear the account activity and start a new transaction, and make sure to pay enough gas as the Goerli network is very congested.


This topic was automatically closed after 30 days. New replies are no longer allowed.