There is a pending, and my activity there is no more activities, because of cleared, and I tried resend the nonce, it failed all the time. how to solve the pending transaction

My address got a pending, and the activity shows there is no more activities, because of cleared, and I tried resend with the pending nonce so many times, it failed all the time. how to solve the pending transaction?

1 Like

Hello @Wsnakes,

First you need to know how many pending transactions you have. Search your address on the relevant block explorer to see the history of the transactions. If you have more than one pending transactions, you need to start canceling from the oldest pending transaction.

Please refer to the following article (read Method 2: Custom nonce carefully) and let us know in case you need further assistance.


only 1 pending. and last more than 7 days. can not cancel and speed up. even I tried nonce. not working. If I delete the wallet, and reload in the new browse, will be work? then there is nomore pending?

Then you need to send a transaction with the nonce of that pending transaction. Try the following steps:

  1. Take the nonce of the pending transaction.
  2. Send a new transaction with the same nonce. If the transaction is on the Ethereum network, you can send a transaction with 0 ETH to your account, with the same nonce as the pending transaction.
  3. Make sure to pay enough gas fee for the transaction to be executed. Use the Advanced gas feature in your MetaMask wallet and choose the following parameters carefully based on the Etherscan gas parameters at the time of the transaction (assuming that the transaction is on the Ethereum network): Max base fee, Priority fee, Gas Limit.

If after trying the above mentioned steps, you still need help, please contact the support team via the following link and click on the large blue box, “Start a Conversation” to contract the support.


I tried what you said before send the message.

when send out 0ETH to my own address, it shows failed immediately.

I remember the pending transaction from a canceled order.

Because it is canceled already online, but the activity still shows the cancel button, so canceled one more time, but the truth is the etherscan already canceled it successfully. so the one more time cancel, caused the pending transaction.

You mean that you searched your address on the relevant block explorer and there is not any pending transactions there? IF yes, you need to clear the activity and nonce data from your MetaMask Settings.
Settings> Advanced> Clear activity and nonce data
If after clearing your wallet activity the issue persists, clear your browser’s cache.
In case the suggestions mentioned above do not resolve the issue, change the network RPC using the following link.
https:// chainlist. org/ (remove the two spaces I inserted in the link)
Click on the small arrow at the bottom of the network box to see the list of the RPCs and connect your wallet and add an appropriate one.

Hope that helps.


The issue finally solved. MetaMask support give solutions is to resend the same nonce with high gas fee, at least 3 times higher.
I did same way before ask for help, but the gas fee didn’t offer enough.

Thanks for MetaMask support

1 Like

I have the same issue but can not to fix it.
4 days ago, I wanted to transfer eth to Era network using era bridge from MetaMask ETH network. However, I had set the ETH fee manually in the previous transaction. I confirmed this new transaction without saying market and the transaction is stuck in the network (it appears as pending.) How can I cancel this transaction? Thanks.
It does not allow any transactions on the ETH network.

If it’s stuck on Ethereum, check your wallet on etherscan and use this article guide to cancel it.

Always check your wallet on block explorer for anything not working.

1 Like