Bridge Error from FTM network to BSC

I had successfully bridged USDC over from the FTM network to BSC
Upon doing so the second time the funds seem to have gotten stuck and on both FTMscan and BSCscan the fund amount is visible but in the form of anyUSDC.

It appears that the funds are stuck inside the anyswap USDC joint wallet

I do not know how to rectify this.

Please help

Hello, has your problem been solved? It seems that there is no problem. If there is still a problem, you can provide your address and I’ll check it for you

1 Like

Hi there

Problem not yet solved


Thank You

Hi Tristan @NativeMinds click Import tokens and add anyUSDC
Token Contract Address: 0x8965349fb649a33a30cbfda057d8ec2c48abe2a2

Go to AnySwap page → Router and then toggle from Router to Pool:

Click to USDC it will give you an option to remove your pool share. Click to Remove put it to however much you want to withdraw and the chain you want to withdraw to.


Thank you very much @Luigi
I now see the positive balance of anyUSDC

The Destination Liquidity is insufficient however does this mean I will need to wait until new liquidity is provided from stake holders? Is there a particular LP Pool that provides that?


@NativeMinds Tristan try page: :slightly_smiling_face: again click to Remove


@Luigi you are a legend :slightly_smiling_face:
Thank you for your help

1 Like