🐛 Bug: MetaMask Add-On Button Not Showing In Firefox

Issue

The MetaMask add-on icon/button is not showing in the Firefox browser UI after installation and configuration, and is unable to be opened via the default extension shortcut “shift + option + M”.

The icon/button and shortcut work as expected in an alternate Firefox browser instance launched with a different Firefox profile.

Steps To Reproduce

  1. Download MetaMask add-on and select “Add” when prompted with permissions.
  2. Set up a new wallet: Select “Get Started” > “Create a Wallet” > “I agree” > Enter password > “Next” > Reveal “Secret Backup Phrase” > Confirm “Secret Backup Phrase” > “All Done”
  3. The add-on icon/button is not showing in the Firefox menu bar or overflow menu.

Attempted Solutions

  • Allow “Run in Private Windows” and attempt opening in a private window
  • Remove add-on, clear all browser cookies and cache, and re-install add-on
  • Disable ad blockers, e.g., uBlock and Firefox Enhanced Tracking Protection prior to installation
  • Disable all add-ons prior to installation
  • Restart Firefox browser
  • Restart computer

Configuration

  • macOS Big Sur 11.4
  • Firefox version: 89.0.2 (64-bit)
  • MetaMask add-on version: 9.6.1

This issue has been resolved by Dave on GitHub and Dave on Reddit. You may search for the posts under the same title listed here because unfortunately, links are not permitted here in the forums.

Right-click on the extensions area of the toolbar, then click customize toolbar, then drag MM extension into the extensions area.

I was able to reproduce this. Oddly enough, when I right click to Customize the toolbar, the addon is certainly there to be added