Chain ID issue - assitance?

I am having the same problem. I cannot change the set up, as it was provided by the “school” doing this course. I am in an Oracle VM VirtualBox with Ganache setting up the test net and truffle. Doing a truffle develop gives me an http of 127.0.0.1:9545. Ganache is supposed to be ChainID of 1337, but it gives me “could not fetch chain ID. Is your RPC URL correct?” Inside of Ganache I see an http of 127.0.0.1:7545 with Network ID of 5777. I have also tried that to no avail. Because this setup came from a zipped file, I do not know where all the JSON files are or all of the Web3 js files are or even Node.js. Why doesn’t Metamask allow us to connect a private test network as we need? This worked with the version of Metamask in March of 2018 (when the “school” made the course).

2 Likes

Hi @ArntheWeeb ,

Sharing the Trufflesuite docs in case it helps. Truffle and MetaMask - Truffle Suite

Does anything in this post from the stackexchange help?

Also seeing these on

1 Like

Also to confirm, same question posed here -

A post was split to a new topic: Is this site safe?