Could not fetch chain ID. Is your RPC correct

Hello, I’ve been trying to connect to the PulseChain Testnet Network and have followed the instructions listed across may websites and their gitlab page.

However, every time I’ve tried to connect to this test network I always receive the error: Could not fetch Chain ID. Is your RPC correct?

I’ve also tried to connect to the network through the Chainlist site. I was able to identify the network by toggling on the Testnets option and searching PulseChain. The ChainID should be 941. This is the error i’m getting from the Chainlist site: Error. Request for method 'eth_chainid on pc.v2b testnet pulsechain / failed

i’ve copied the New RPC as seen in the attached pic rpc.v2b. testnet.pulsechain dot com
Chain ID: 941
Currency Symbol: tPLS
and block explorer scan dot v2b.testnet.pulsechain

Within metamask i’ve switched between other networks and i’ve even deleted the metamask extension from the Brave Browser and also removed the brave browser from my Mac Desktop computer. I reinstalled them both and still having the same issue.

With a second Metamask wallet and second address I was fine adding the PulseChain Testnet 2b network okay… however i’ve tried for several days now using Metamask as a brave extension and have had no luck. Any suggestions why I’m having this issue would be a huge help. thank you in advance!!

Pls has 3 test networks. You can try to fill in 940 / 941 / 942

Thank you @Tksly, i’ve tried all the pls test networks and still have the same error message. As a test, i tried to add the smart chain testnet and had no issues. so i’m not sure why the pulse test is giving me a problem. thanks for trying to help me troubleshoot this…

Uploading: image.png…
Click here to configure it automatically.


This topic was automatically closed after 30 days. New replies are no longer allowed.