Change Spending Limit for a Smart Contract or Refreshing - Reset Smart Contract

Hi!

I tried to stake some tokens in a Pool and when I clicked on the Enable button it popped up a Metamask dialog box asking me to approve spending limit. Instead of accepting “Unlimited” I entered the number 10.
Now I can’t stake in that pool. How do I change the number 10 in that Smart Contract? Or at least, How do I ‘reset’ that option in order to start over again from scratch?
The smart contract is in the KCC blockchain…
Thanks in advance,