Charged for Failed Transactions?

Hi all, and thanks in advance for reading. This morning I tried to get some P-ETH, but all the transaction failed, or resulted in a 0, yet I still got charged some. See screenshot below. What’s this about? How do I get my cash back?

1 Like

Hey @tsb023, welcome to the MetaMask community! :fox_face:

Gas fees are still charged for failed transactions. Unfortunately, all transactions on the blockchain are irreversible and you will not be able to get these fees back. Here is more information on our Knowledge Base:


Thanks for the reply, and the link. I guess I just learnt how to “DYOR”, the hard way.

Incidentally, what makes a transaction succeed or fail?

You’re welcome, sorry to hear about the lost fees :frowning:

There can be a few reasons why transactions fail, but most commonly it is because of gas issues. Here is more information on our Knowledge Base:

1 Like

Thanks for the clarification, Winnie.

I have a similar sob story, but the “user error on my part” is the result of an unreadable Transaction Data Error Message - ["Cannot read properties of undefined (reading 'map')"](

How am I supposed to know the problem if the error messages are unreadable? Wouldn’t any reasonable person try the transaction again?
Has anyone else gotten this error message?

Hey @Webstar, according to Etherscan with the wallet address you sent, it looks like the errors are for out of gas issues.

Here is more information on our Knowledge Base:

Appreciate the prompt response, Winnie.
I shouldn’t have to check Etherscan to see why my transaction didn’t go through.

The problem is solely with Metamask’s error message. If it had said “Warning! Error encountered during contract execution [Out of gas]”, I would have increased my gas limit.
As a result of the missing information, I tried the transaction 4 more times, losing a significant amount of money.

What can be done?

Sorry to hear this has happened @Webstar, it can definitely be frustrating.

When transactions fail, a notification does appear on your MetaMask wallet, along with it showing in the Activity section of your wallet.

The article on the Knowledge Base I linked above will provide more information, along with this one:

I did see all the fail notifications in Metamask. It is this error message that I posted in the previous message.

What can we do about an error message that users cannot read? How was I to know why that transaction failed?
Who is responsible for the failure to follow fundamental user experience practices.

Would you be able to provide a screenshot of the error message? That would provide more helpful information.

In terms of who is responsible for failed transactions, please keep in mind that the blockchain is decentralized and that MetaMask is a non-custodial wallet.

Thank you for taking a look

Thanks for sharing the screenshot :slight_smile:

The error shows up under Transaction data because the transaction has failed so the data shows up as undefined. To see the reason why the transaction has failed, you can click View on block explorer by Status

But I do see what you mean that it would be beneficial to see why the transaction has failed on the MetaMask UI along with the block explorer. If you would like, you can post about it on Feature Requests / Ideas - MetaMask

Why do other users get informative error messages? https:/

Did I sign up for the wrong account, one that doesn’t get messages?

The error displays on the block explorer, such as Etherscan :point_down:

How is a new user supposed to know to check error details on an external website?
Wouldn’t that behavior be similar to a scam?

I’m afraid it was impossible for me to know why the transaction failed. Metamask is unequivocally responsible for 4 of my 5 failed transactions. What can we do to address this?
Promising to add a new Metamask feature far in the future isn’t relevant to this complaint.

Simply going to an external website would not be a scam. If the external website was asking for personal information such as your Secret Recovery Phrase, that would be a scam.

You can see why your transaction failed on the block explorer, such as Here is more information on our Knowledge Base:

MetaMask is not responsible for your failed transactions, these are transactions that have taken place on the blockchain, which itself is decentralized. MetaMask is a non-custodial wallet that simply acts as an interface to confirm these transactions.

There is also a problem with the Advanced Edit Properties of the Estimated Gas Fees feature. Playing with the parameters, Metamask will not disable the Submit button if the values are too low. The error message says, “Gas limit must be at least 218318”.

My input was within Metamask’s acceptable range. Isn’t Metamask responsible when the gas fees fall short?

Metamask is an interface for blockchain transaction, for which it charges a percent fee. It is responsible when its bugs lead to lost costs.
Percent fee details, “A dynamic service fee that ranges between 0.3% - 0.875% is automatically factored into each quote, which supports ongoing development to make MetaMask even better.”

Should I post a new topic? @nakedwinnie

If you would like you edit the gas settings, it is ultimately your decision to make on your behalf. Here is more information that may help you on our Knowledge Base:

When gas fees fall short, this is because not enough funds for gas was provided to complete the transaction. MetaMask does not have any control over these gas fees, they are caused by network demand and congestion, and can be very volatile at times.

The 0.875% fee for MetaMask Swaps is not a gas fee, but a fee that MetaMask charges for using its swap service. This is only for using MetaMask swaps, and is only charged if your transaction is successful. Keep in mind that gas fees are still paid for failed transactions.

If you have a new question or issue, you can create a new topic :slight_smile:

This topic was automatically closed after 30 days. New replies are no longer allowed.