Custom token issues

I transferred a token to my Metamask wallet and the transaction was successful. I am unable to add this token through the custom token process. I followed all procedures as suggested in this community, but without success. Help please.

I also bought some ETH. It shows under “activity”, but not as an “asset”. When will it show as asset?

Thanks

0xf4e2c0ece3aa58c36858772e044daebce4dcb09c810dd76b8be37f86e58d52ba

Thank you, but that is the frustration as I am adding the contract address and decimal right, but it is not importing.

Yes, ETH mainnet. Really do not know what to do.
Maybe some settings not right?

I just did and it still does not work. I have added the contract address manually and copy and pasted it. I just have an “infinity wheel” that just keeps turning and turning.

Would you be able to send a screenshot? By infinity wheel do you mean that it is stuck loading?

Hi Winnie

Yes, it does not import. It is stuck, so after 5-10 mins I go out of the program.

Could it be that my settings are not correct?

Also, I bought ETH sometime ago and it reflects in my “activity”, but not under “assets”. Why is this so?

Regards

Johan

Try importing the token by clicking the MetaMask logo here :point_down:

https://www.coingecko.com/en/coins/wilder-world

ETH should be showing up under your assets in Ethereum mainnet by default, try these steps in our Knowledge Base:

1 Like

Halleluja! Thank you. Problem solved.

1 Like